Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002669 [Croquet] Hedgehog major always 02-04-06 01:00 02-05-06 04:38
Reporter andreas View Status public  
Assigned To Croqueteer
Priority normal Resolution fixed  
Status assigned  
Summary 0002669: TSpinner problems
Description When creating a structure like here:
  Frame[Spinner[Group[Cube]]]
It seems like one cannot select a point on the spinner (the little cube is invisible) and the rotation code fails due to "event selection point" being nil.
Additional Information
Attached Files  Rube-Domino.st [^] (5,651 bytes) 02-05-06 04:00

- Relationships

- Notes
(0003696 - 69 - 69 - 69 - 69 - 69 - 69)
Croqueteer
02-04-06 03:53

This was fixed. Probably introduced the problem when I refactored it.
 
(0003703 - 248 - 248 - 248 - 248 - 248 - 248)
andreas
02-05-06 03:56

There seem to be more problems here. Greg just showed me some code (I'll attach it as soon as I have a copy) where picking the object shows the little cube in a completely wrong place and 9 out of ten times trying to rotate the object does nothing.
 
(0003704 - 788 - 798 - 798 - 798 - 798 - 798)
Croqueteer
02-05-06 04:38

Bear in mind that the TSpinner does not work properly if it and its content frames do not completely correspond. That is, if the content frame or other child frame has a non-identity transform, the TSpinner will not perform properly. This is because it actually refers to "self" for determining transforms, etc - where in fact it should be using the current TXSelection frame. This usually works OK if the transforms of the object owner (the TSpinner frame) and the contents correspond, which they usually do. To fix this, it is necessary to transform the point which is provided in the frame local coordinates, into the self local coordinates (simple matrix transform), which will make everything pretty again. I can leave this as a simple exercise in first year math... or I can fix it.
 

- Issue History
Date Modified Username Field Change
02-04-06 01:00 andreas New Issue
02-04-06 03:53 Croqueteer Status new => resolved
02-04-06 03:53 Croqueteer Resolution open => fixed
02-04-06 03:53 Croqueteer Assigned To  => Croqueteer
02-04-06 03:53 Croqueteer Note Added: 0003696
02-04-06 03:56 Croqueteer Status resolved => assigned
02-05-06 03:56 andreas Note Added: 0003703
02-05-06 04:00 andreas File Added: Rube-Domino.st
02-05-06 04:38 Croqueteer Note Added: 0003704


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
46 total queries executed.
34 unique queries executed.
Powered by Mantis Bugtracker