Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000029 [tweak] minor always 06-15-04 17:18 06-29-04 00:07
Reporter bert View Status public  
Assigned To andreas
Priority normal Resolution no change required  
Status resolved  
Summary 0000029: forEach: #tick do: [...] until: #mouseUp
Description The expression
    self forEach: #tick do: aBlock until: #mouseUp
does not eval aBlock at all, and does not return on mouse-up. OTOH,
    self clock forEach: #tick do: aBlock until: {self. #mouseUp}
does evaluate the block but does not return.
Additional Information
Attached Files

- Relationships

- Notes
(0000025 - 603 - 733 - 733 - 733 - 733 - 733)
andreas
06-29-04 00:07

<obj> forEach: #tick do: aBlock until: #mouseUp.

Evaluates aBlock only if <obj> generates #tick events - and player's don't #tick on their own.

  self clock forEach: #tick do: aBlock until: {self. #mouseUp}

won't work since this expression doesn't take "full specs" at this point (sorry about this). BTW, I'm not sure this idiom is any good anyway - I added it early on but it seems that the only useful pattern so far has been handling #mouseMove events so it may be better to introduce specific methods, e.g.,

  <hand> forEachMouseMoveDo:until:
  <clock> forEachTickDo:until:

Thoughts?
 

- Issue History
Date Modified Username Field Change
06-15-04 17:18 bert New Issue
06-15-04 17:19 bert Severity feature => minor
06-29-04 00:07 andreas Status new => resolved
06-29-04 00:07 andreas Resolution open => no change required
06-29-04 00:07 andreas Assigned To  => andreas
06-29-04 00:07 andreas Note Added: 0000025


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
36 total queries executed.
31 unique queries executed.
Powered by Mantis Bugtracker