Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003083 [Squeak Packages] XML-Yaxo minor always 02-24-06 14:55 10-31-07 16:18
Reporter pmm View Status public  
Assigned To michael
Priority normal Resolution fixed  
Status resolved  
Summary 0003083: [FIX] #initialize sent twice XMLTokenizer and subclasses
Description because of the implementation of new in XMLTokenizer

^super new initialize

instances of XMLTokenizer or subclasses receive #initailize twice.
The correct implementation would be

^self basicNew initailize
Additional Information
Attached Files

- Relationships

- Notes
(0011405 - 61 - 61 - 61 - 61 - 61 - 61)
michael
10-31-07 16:18

removed the new methods because as of 3.8 new also initialize
 

- Issue History
Date Modified Username Field Change
02-24-06 14:55 pmm New Issue
03-01-06 19:28 MarcusDenker Project Squeak => Squeak Packages
07-17-06 20:21 MarcusDenker Status new => assigned
07-17-06 20:21 MarcusDenker Assigned To  => michael
10-31-07 16:18 michael Status assigned => resolved
10-31-07 16:18 michael Resolution open => fixed
10-31-07 16:18 michael Note Added: 0011405


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
38 total queries executed.
32 unique queries executed.
Powered by Mantis Bugtracker