Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003168 [Croquet] Hedgehog major always 03-01-06 00:38 03-30-06 00:22
Reporter mpm View Status public  
Assigned To
Priority normal Resolution open  
Status closed  
Summary 0003168: Portals: only the avatar that opens a closed portal can walk through it
Description in the demo croquet world, if the other guy opens a portal, you cannot walk through it, but he (the guy who opened the portal), can. For instance, on my Mac, I open fish world, and the avatar on my Mac can go through the portal and into the world. The PC user cannot. Then the PC user opens up the mars rover wold and he can enter it, but the Mac user cannot enter that wold... he can look through the portal though...

This is probably the real issue behind this report 003025
Additional Information
Attached Files

- Relationships
related to 0003025new  walking through portal sometimes misses 

- Notes
(0004324 - 260 - 272 - 272 - 272 - 272 - 272)
schwa
03-03-06 19:36

I was unable to reproduce this bug.

Mark, did you mean that this bug is the source of the bug erroneously perceived/reported as 003025, or the other way around? I can see how the latter might be true... by chance 003025 generated the symptom described her.
 
(0004330 - 670 - 680 - 680 - 680 - 680 - 680)
mpm
03-03-06 21:52

Applying the changeset NewIslandPastMessageFix.2.cs.gz from bug 0002987 seems to help a lot. Another thing that sems to help a is avoiding having the morphic halo around the harnessMorph by carefully keeping the mouse inside the harness morph. This is starting to feel like a timing issue, where when the framerate drops to low levels, the view angle is not what we expect and we "miss" the portal. When I traverse the portal sucessfully, it is always a fast smooth transtition. When I seem to go into the portal but end up back in the world I started from, there is always a long lag and a slow transition. weird. I'm testing between a Mac and a PC, for it its worth.
 
(0004625 - 60 - 60 - 60 - 60 - 60 - 60)
mpm
03-30-06 00:22

I cannot reproduce this anymore, so it seemes fixed to me...
 

- Issue History
Date Modified Username Field Change
03-01-06 00:38 mpm New Issue
03-01-06 00:39 mpm Relationship added related to 0003025
03-03-06 19:36 schwa Note Added: 0004324
03-03-06 21:52 mpm Note Added: 0004330
03-30-06 00:22 mpm Note Added: 0004625
03-30-06 00:22 mpm Status new => closed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
46 total queries executed.
34 unique queries executed.
Powered by Mantis Bugtracker