Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003283 [Squeak] SqueakMap major always 03-10-06 14:07 03-10-06 16:11
Reporter gsa View Status public  
Assigned To gokr
Priority normal Resolution duplicate  
Status closed   Product Version 3.9
Summary 0003283: Error upgrading SqueakMap
Description When trying to open SqueakMap Package Loader and it ask by upgrading to new 2.1 version, after work sometime, appear the error: "Error occurred when updating map: SystemDictionary>>logChange:"

This error happens with a 3.9a 0007006 image.
Additional Information Going to the debugger I can see: "SystemDictionary(Object)>>doesNotUnderstand: #logChange:" then, the solution is simple, find the method and use SmalltalkImage current logChange: instead Smalltalk logChange:

The class to patch is SMInstallationRegistry, method #noteInstalledPackageWithId: aPackageId autoVersion: aVersion name: aName.

But this class isn't in the current SMPackage, seems that the updating process must work sometime to download this object.

In short, the solution is patching the method, but I don't know how/were find this class (SMInstallationRegistry) to patch it and let ready to be downloaded correctly by the upgrading SM process.
Attached Files

- Relationships

SYSTEM WARNING: Creating default object from empty value

SYSTEM WARNING: Creating default object from empty value

duplicate of 0003274closed gokr SqueakMap crash with SystemDictionary doesNotUnderstand: #logChange: 
duplicate of 0002912closed gokr Error when updating map: SystemDictionary>>logChange: 

- Notes
(0004421 - 123 - 135 - 135 - 135 - 135 - 135)
gsa
03-10-06 14:59
edited on: 03-10-06 15:44

Sorry, duplicated post, I've not seen the previous 3274. Well, in my own post here, I propose a solution. Hope this help.

 
(0004423 - 79 - 97 - 97 - 97 - 97 - 97)
MarcusDenker
03-10-06 16:11

duplicate of:

0002912: Error when updating map: SystemDictionary>>logChange:
 

- Issue History
Date Modified Username Field Change
03-10-06 14:07 gsa New Issue
03-10-06 14:07 gsa Status new => assigned
03-10-06 14:07 gsa Assigned To  => gokr
03-10-06 14:09 gsa Issue Monitored: gsa
03-10-06 14:59 gsa Note Added: 0004421
03-10-06 14:59 gsa Note Added: 0004422
03-10-06 15:00 gsa Note Deleted: 0004422
03-10-06 15:00 gsa Note Edited: 0004421
03-10-06 15:44 gsa Note Edited: 0004421
03-10-06 16:07 MarcusDenker Relationship added duplicate of 0003274
03-10-06 16:10 MarcusDenker Relationship added duplicate of 0002912
03-10-06 16:11 MarcusDenker Status assigned => closed
03-10-06 16:11 MarcusDenker Note Added: 0004423
03-10-06 16:11 MarcusDenker Resolution open => duplicate
03-10-06 16:11 MarcusDenker Fixed in Version  => 3.9


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
66 total queries executed.
40 unique queries executed.
Powered by Mantis Bugtracker