Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003306 [Croquet] Hedgehog minor always 03-14-06 17:49 02-14-07 21:44
Reporter howardstearns View Status public  
Assigned To mpm
Priority normal Resolution fixed  
Status resolved  
Summary 0003306: connection closed while waiting for data
Description Run CroquetMaster and CroquetParticipant on the same Macintosh image. Delete the participant. Get DNU tempNames within decompile while trying to print an error about connection closed while waiting for data.
(Don't inspect any of the upper frames. You'll get lots of recursive errors.)

Note that to run a Master and Participant, you need the fix to 2986.
This doesn't happen on Windows, which may be because Windows doesn't care about open connections -- good thing that Macintosh checks for you! I haven't tested on Linux.
Additional Information Having multiple harnesses running OpenAL as master and participant on the same machine is not something we are worrying about or trying to support right now. It is far more important to get streaming OpenAL going so we can talk to each other when we are on different machines. It is unclear to me how I would use (or test) streaming OpenAL for speech on a single machine. So... this should not be listed as a major bug
Attached Files  ConnectionClosedTrap.1.cs.zip [^] (1,747 bytes) 03-28-06 19:49

- Relationships
related to 0002986resolved andreas apple macintosh can be master or participant, but not both 

- Notes
(0004479 - 81 - 81 - 81 - 81 - 81 - 81)
pmoore
03-14-06 23:24

Howard, I couldn't reproduce this and I'm unsure what this has to do with OpenAL.
 
(0004488 - 247 - 259 - 259 - 259 - 259 - 259)
howardstearns
03-15-06 17:54

Peter reports that he has seen this error intermittently when closing a participant, without having openAL loaded.

The intermitancy indicates that it may be a timing issue, which may or may not be tickled by the presence of openAL in the image.
 
(0004489 - 271 - 271 - 271 - 271 - 271 - 271)
pmoore
03-15-06 18:01

Not exactly. I saw the error even without having the OpenAL package (or any other package from U of M) loaded. So to clarify, OpenAL need not be present at all in the image for this error to occur. It is much more likely that the problem is with the fix to issue 0002986.
 
(0004491 - 443 - 449 - 449 - 449 - 449 - 449)
andreas
03-15-06 22:47

There is nothing special about Macs or OpenAL here - the connection close is the natural way for a participant to say good bye to the router. The only reason you see it is that the router logs some additional information when the participant goes away (simply for debugging purposes) and apparently something goes wrong whe it's trying to print this log. Not sure what that is but I'm pretty sure it happens in TMessageRelay>>runReaderProcess.
 
(0004587 - 705 - 747 - 747 - 747 - 747 - 747)
howardstearns
03-28-06 19:52

The attached file doesn't fix the problem (I still don't know the cause), but it does provide a hack workaround. Here's the changeset preamble:

We normally trap errors and tell everyone about the error, including the signalerContext.
The normal way we deal with the news is to destroy ourself.
It is also normal to signal ConnectionClosed when a participant leaves.
Alas, it sometimes happens that the signalerContext is all messed up during ConnectionClosed,
and so we get recursive print errors tryng to gather the stack.
This HACK still tells everyone to #handleError:stack: for other errors, but tells them to directly #destroy (with no #handleError:stack: intervention) on ConnectionClosed.
 
(0009795 - 92 - 98 - 98 - 98 - 98 - 98)
mpm
02-14-07 21:44

you can now run multiple worlds on the same machine with OpenAL.
this was fixed a while ago
 

- Issue History
Date Modified Username Field Change
03-14-06 17:49 howardstearns New Issue
03-14-06 17:49 howardstearns Relationship added related to 0002986
03-14-06 23:04 mpm Severity major => minor
03-14-06 23:04 mpm Additional Information Updated
03-14-06 23:24 pmoore Note Added: 0004479
03-15-06 17:51 howardstearns Summary openAL connection closed while waiting for data => connection closed while waiting for data
03-15-06 17:54 howardstearns Note Added: 0004488
03-15-06 18:01 pmoore Note Added: 0004489
03-15-06 22:47 andreas Note Added: 0004491
03-28-06 19:49 howardstearns File Added: ConnectionClosedTrap.1.cs.zip
03-28-06 19:52 howardstearns Note Added: 0004587
02-14-07 21:44 mpm Status new => resolved
02-14-07 21:44 mpm Resolution open => fixed
02-14-07 21:44 mpm Assigned To  => mpm
02-14-07 21:44 mpm Note Added: 0009795


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
68 total queries executed.
46 unique queries executed.
Powered by Mantis Bugtracker