Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003328 [Squeak] Morphic minor always 03-20-06 10:54 03-21-06 15:45
Reporter bert View Status public  
Assigned To
Priority normal Resolution fixed  
Status closed   Product Version 3.9
Summary 0003328: Ctrl-E does not look for strings
Description Seen in 7013: Marking a string and pressing Ctrl-E does not invoke the search. The menu option works, though

Additional Information
Attached Files

- Relationships

- Notes
(0004527 - 1197 - 1668 - 1668 - 1668 - 1668 - 1668)
MarcusDenker
03-20-06 19:32

seems to be related to the addition of the dupAllCtrlAltKeysPref changeset... something went
wrong (e.g. the preference is not there... strange.)

(Apple-E works on the mac...)

        Change Set: dupAllCtrlAltKeysPref-dew
    Date: 13 December 2004
    Author: Doug Way

    Adds a new preference duplicateAllCtrlAndAltkeys to duplicate all Ctrl and Alt modifier key
    commands, which causes all Ctrl key commands to behave the same as Alt-key commands.
    The original Ctrl (a.k.a. 'shift') key commands are still available via Ctrl-Shift and Alt-Shift.

    This differs from the existing ctrlAlt prefs which only duplicate/swap the eight editing keys.
    Also includes code to prevent these other two conflicting prefs from being activated at the
    same time.

    The three related prefs (swapCtrlAndAltKeys, duplicateCtrlAndAltKeys,
    duplicateAllCtrlAndAltKeys) should really be made into a radio button preferences set
    sometime in the future (like the Halo look preferences), since only one can be turned on at
    a time. This would eliminate the need for the #changed methods.

    See 'modifier' discussion on squeak-dev from 12/3/2004 for more details on why this was provided.
 
(0004529 - 1702 - 1857 - 1857 - 1857 - 1857 - 1857)
MarcusDenker
03-20-06 23:15

looks like I forgot the postscript... will be in 7015


    Preferences addPreference: #duplicateAllControlAndAltKeys category: #keyboard default: true balloonHelp: 'If true, duplicates all alt- keys as ctrl-keys (making ctrl-c be copy as well as alt-c).
Cannot be true if swapControlAndAltKeys or duplicateControlAndAltKeys are true.'.

Preferences addPreference: #duplicateControlAndAltKeys category: #keyboard default: false balloonHelp: 'If true, duplicates some alt- keys as ctrl- keys (making ctrl-c be copy as well as alt-c).
Cannot be true if swapControlAndAltKeys or duplicateAllControlAndAltKeys are true.'.

Preferences addPreference: #swapControlAndAltKeys category: #keyboard default: false balloonHelp: 'If true, swaps some control- and alt-keys (making ctrl-c be copy instead of alt-c).
Cannot be true if duplicateControlAndAltKeys or duplicateAllControlAndAltKeys is true.'.

(Preferences preferenceAt: #honorDesktopCmdKeys) categoryList: #(#keyboard #menus).

(Preferences preferenceAt: #duplicateAllControlAndAltKeys) rawValue: false.
(Preferences preferenceAt: #duplicateControlAndAltKeys) rawValue: false.
(Preferences preferenceAt: #swapControlAndAltKeys) rawValue: false.

(Preferences preferenceAt: #duplicateAllControlAndAltKeys) changeInformee: InputSensor changeSelector: #duplicateAllControlAndAltKeysChanged.
(Preferences preferenceAt: #duplicateControlAndAltKeys) changeInformee: InputSensor changeSelector: #duplicateControlAndAltKeysChanged.
(Preferences preferenceAt: #swapControlAndAltKeys) changeInformee: InputSensor changeSelector: #swapControlAndAltKeysChanged.

(Preferences preferenceAt: #duplicateAllControlAndAltKeys) preferenceValue: true.
 
(0004544 - 13 - 13 - 13 - 13 - 13 - 13)
MarcusDenker
03-21-06 15:45

fixed in 7015
 

- Issue History
Date Modified Username Field Change
03-20-06 10:54 bert New Issue
03-20-06 10:54 bert Status new => assigned
03-20-06 10:54 bert Assigned To  => KenCausey
03-20-06 19:32 MarcusDenker Note Added: 0004527
03-20-06 20:22 KenCausey Assigned To KenCausey =>
03-20-06 20:22 KenCausey Status assigned => new
03-20-06 20:22 KenCausey Category Any => Morphic
03-20-06 23:15 MarcusDenker Note Added: 0004529
03-21-06 15:45 MarcusDenker Status new => closed
03-21-06 15:45 MarcusDenker Note Added: 0004544
03-21-06 15:45 MarcusDenker Resolution open => fixed
03-21-06 15:45 MarcusDenker Fixed in Version  => 3.9


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
49 total queries executed.
37 unique queries executed.
Powered by Mantis Bugtracker