Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003369 [Croquet] Hedgehog minor always 03-28-06 17:05 02-14-07 21:43
Reporter howardstearns View Status public  
Assigned To mpm
Priority normal Resolution fixed  
Status resolved  
Summary 0003369: openAL crash with multiple croquet morphs on the same machine
Description Open Sailing Master and Participant (e.g., as is typical for debugging collaboration using a single machine).

Get a VM crash in OpenAL>initialize.

This occurs with Croquet Win32 VM 1.0.0

This does NOT occur when opening, e.g., MPEG Demo Master and Sailing Master simultaneously, or when opening Master and Participant in different Squeaks.
Additional Information
Attached Files

- Relationships
duplicate of 0003379closed  OpenAL: Only one context is ever created 

- Notes
(0004592 - 141 - 141 - 141 - 141 - 141 - 141)
mpm
03-28-06 21:14

this is a convenience issue for developers who are trying to develop mutli-user applications but only have one machine. not a show stopper...
 
(0004712 - 153 - 153 - 153 - 153 - 153 - 153)
andreas
04-08-06 11:04

BTW, is this is still an issue with the FFI version? I'd expect not since most likely the crash was caused with lack of support for AL context switching.
 
(0004730 - 417 - 441 - 441 - 441 - 441 - 441)
pmoore
04-10-06 19:57

It will still crash in the current version. It's not smart enough about switching between multiple contexts (yet). Bad things happen when the wrong context is active.

Could somebody with FFI experience please take a critical look at the ALC calls in OpenAL (and the methods that use them, namely OpenAL>>createContext and OpenAL>>destroyContext). FFI is new to me and I've made more than a few educated guesses. ;)
 
(0009794 - 98 - 98 - 98 - 98 - 98 - 98)
mpm
02-14-07 21:43

you can now have multiple worlds running on the same machines with OpenAL and switch between them.
 

- Issue History
Date Modified Username Field Change
03-28-06 17:05 howardstearns New Issue
03-28-06 21:14 mpm Note Added: 0004592
03-28-06 21:14 mpm Severity crash => minor
03-28-06 21:14 mpm Summary openAL crash with multiple croquet morphs => openAL crash with multiple croquet morphs on the same machine
03-29-06 01:43 andreas Relationship added duplicate of 0003379
04-08-06 11:04 andreas Note Added: 0004712
04-10-06 19:57 pmoore Note Added: 0004730
04-10-06 23:12 pmoore Issue Monitored: pmoore
02-14-07 21:43 mpm Status new => resolved
02-14-07 21:43 mpm Resolution open => fixed
02-14-07 21:43 mpm Assigned To  => mpm
02-14-07 21:43 mpm Note Added: 0009794


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
58 total queries executed.
42 unique queries executed.
Powered by Mantis Bugtracker