Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003454 [Croquet] Hedgehog minor always 04-10-06 17:25 06-19-06 21:46
Reporter howardstearns View Status public  
Assigned To andreas
Priority normal Resolution fixed  
Status resolved  
Summary 0003454: MPEG Demo doesn't loop
Description In beta 4, the movie played continuously when you clicked on the TMpegDisplayMorph, and stopped only when you clicked again.

It looks like beta 6 is still trying to do the same thing, but it stops after one play and will not restart.

(Tested on Mac and Windows.)
Additional Information
Attached Files  fix-3454.1.cs [^] (676 bytes) 05-13-06 02:09

- Relationships

- Notes
(0004904 - 556 - 644 - 644 - 644 - 644 - 644)
bfowlow
05-13-06 02:13
edited on: 05-13-06 02:14

Attaching a fix for at least the Croquet-specific case.

The problem is that some changes to MpegDisplayMorph and MPEGFile
are making the morph forget its relationship to the MPEGFile name.

Specifically... the MPEGFile is created through a path that opens
an intermediate buffer, but this path forgets the intermediate file name.
Meanwhile, rewindMovie: works by re-opening "mpegFile filename"
but the buffered mpegFile has forgotten its name.

So the fix is a code path that creates a buffered MPEGFile
and remembers the original path name.

 
(0005281 - 20 - 20 - 20 - 20 - 20 - 20)
andreas
06-19-06 21:46

Added to repository.
 

- Issue History
Date Modified Username Field Change
04-10-06 17:25 howardstearns New Issue
05-13-06 02:09 bfowlow File Added: fix-3454.1.cs
05-13-06 02:13 bfowlow Note Added: 0004904
05-13-06 02:14 bfowlow Note Edited: 0004904
05-13-06 02:14 bfowlow Note Edited: 0004904
06-19-06 21:46 andreas Status new => resolved
06-19-06 21:46 andreas Resolution open => fixed
06-19-06 21:46 andreas Assigned To  => andreas
06-19-06 21:46 andreas Note Added: 0005281


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
48 total queries executed.
33 unique queries executed.
Powered by Mantis Bugtracker