Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003465 [Croquet] Hedgehog minor always 04-13-06 23:39 12-04-06 21:48
Reporter howardstearns View Status public  
Assigned To howardstearns
Priority normal Resolution won't fix  
Status resolved  
Summary 0003465: morphic content not replicated
Description It looks like the all the Hedgehacks-Morphic stuff (and the MPEG player based on them) do not really copy the bits onto the island. As a result, you can synch up with something that has this stuff, but your window will just be blank unless you have the files on your disk to which the filenames refer. (So you'd better not create stuff with absolute url's.)

I've verified, for example, that if you rename the flash movie and the fish tutorials out of the way and then synch up to a master that has them, your screens will just be blank.
Additional Information I think Harness>>dropForm: shows a better way to do this, where the bits (the Form) appears as an argument to the replicated messages that cause the replicated content to be made.
Attached Files

- Relationships

- Notes
(0008539 - 723 - 774 - 774 - 774 - 774 - 774)
howardstearns
12-04-06 21:48

These have been changed to use EmbeddedApp, which has a means of recording state in a replicated way so that new user's can join and get to the same state. However:
 
1) That doesn't mean that all the demo examples actually do record sufficient state. (I haven't checked, and as original reporter, I don't care.)

2) Some Morphic stuff might have "state" that is just a handle, and there is still an implied environment, with additional data in the image or file system.

For example, an EmbeddedApp to a Squeak Project will fail on both counts. But I'm ok with that because there are better ways of doing things now, and the Squeak Project is more of a quick-and-dirty example than an actual core Croquet feature.
 

- Issue History
Date Modified Username Field Change
04-13-06 23:39 howardstearns New Issue
12-04-06 21:48 howardstearns Status new => resolved
12-04-06 21:48 howardstearns Resolution open => won't fix
12-04-06 21:48 howardstearns Assigned To  => howardstearns
12-04-06 21:48 howardstearns Note Added: 0008539


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
34 total queries executed.
29 unique queries executed.
Powered by Mantis Bugtracker