Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003502 [Squeak] Morphic minor always 04-25-06 00:17 04-25-06 16:27
Reporter tbn View Status public  
Assigned To
Priority normal Resolution fixed  
Status closed   Product Version 3.9
Summary 0003502: Crash when running ticking script
Description - run "EllipseMorph new openInWorld" from a Workspace in Sq3.9#7024
- click on the light blue halo button to open an scripting viewer (the one with the eye)
- after the script viewer opens on the right side drag the "forward by" script onto the desk and select "ticking" as script event instead of "normal"
- you should get a "PasteUpMorph(Object)>>doesNotUnderstand: #userCustomEventNames" error now

Additional Information
Attached Files  screen.png [^] (11,363 bytes) 04-25-06 00:17
 PasteUpMorph-u...mEventNames.st [^] (310 bytes) 04-25-06 04:57
 PasteUpMorph-*...s-scripting.st [^] (894 bytes) 04-25-06 05:12

- Relationships

- Notes
(0004789 - 67 - 67 - 193 - 193 - 193 - 193)
korakurider
04-25-06 03:21

seems about same problem as http://bugs.impara.de/view.php?id=3496. [^]
 
(0004790 - 965 - 1091 - 1091 - 1091 - 1091 - 1091)
wiz
04-25-06 05:12

Hi tbn, korakurider

Recreating the bug using tbn's formula and tracing things back to the routines showed they were written in 2003 by nk.

Going back to my trusty 3.9withAllChanges from 3.0 located the missing rountine which I filed out and will upload here as
PasteUpMorph-u...mEventNames.st

That solves the problem complained about.

Of course the question remains why was is missing? And are there others that got lost at the same time. This looks like the MC catagory change problems.

Sure enough the other
PasteUpMorph methodsFor: '*customevents-scripting'
have gone missing as well.

I'll upload the catagory fileout
PasteUpMorph-*...s-scripting.st
as well.

Harvesters (Hi Marcus :-) ), as you are the ones what lost 'em. I put on you the responsibility of making sure you know why they were lost. And if anything else was lost with them. And making the right decision of how much of them to return.

Yours in service, Jerome Peace
 
(0004791 - 142 - 178 - 178 - 178 - 178 - 178)
wiz
04-25-06 05:17

Reminder sent to: korakurider

Hi Marcus,

Here are two choices of fix.

Please look into what happened. And if anything else got lost at the same time.

Cheers -- Jer
 
(0004792 - 104 - 116 - 116 - 116 - 116 - 116)
wiz
04-25-06 05:34

Reminder sent to: MarcusDenker, tbn

Hi Marcus,

Last note was meant for you. I forgot how to send reminders to more than one person. --jer
 
(0004794 - 130 - 153 - 153 - 262 - 262 - 262)
wiz
04-25-06 05:48

Confirmed:
 Morph is missing this catagory and all of its methods also. That is what 0003500 is reporting problems about.

-- Jer
 
(0004798 - 390 - 474 - 474 - 474 - 474 - 474)
MarcusDenker
04-25-06 09:50

Hi,

I think I know what happeded: We loaded diego's changesets, and in these, some methods
got categoriesed as *customevents. This then means, that Monticello will not save them
as part of e.g. the Morphic package...

How to fix it:

- get 7022
- load diegos changesets
- save mc package *custumevents
- load that in 7024
- recategorize the methods

I will do this for 7025
 
(0004808 - 13 - 13 - 13 - 13 - 13 - 13)
MarcusDenker
04-25-06 16:27

fixed in 7025
 

- Issue History
Date Modified Username Field Change
04-25-06 00:17 tbn New Issue
04-25-06 00:17 tbn File Added: screen.png
04-25-06 00:18 tbn Issue Monitored: tbn
04-25-06 03:21 korakurider Note Added: 0004789
04-25-06 04:57 wiz File Added: PasteUpMorph-u...mEventNames.st
04-25-06 05:12 wiz Note Added: 0004790
04-25-06 05:12 wiz File Added: PasteUpMorph-*...s-scripting.st
04-25-06 05:17 wiz Issue Monitored: korakurider
04-25-06 05:17 wiz Note Added: 0004791
04-25-06 05:34 wiz Issue Monitored: MarcusDenker
04-25-06 05:34 wiz Note Added: 0004792
04-25-06 05:48 wiz Note Added: 0004794
04-25-06 09:50 MarcusDenker Note Added: 0004798
04-25-06 16:27 MarcusDenker Status new => closed
04-25-06 16:27 MarcusDenker Note Added: 0004808
04-25-06 16:27 MarcusDenker Resolution open => fixed
04-25-06 16:27 MarcusDenker Fixed in Version  => 3.9


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
74 total queries executed.
45 unique queries executed.
Powered by Mantis Bugtracker