Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003505 [Squeak] Morphic crash always 04-26-06 11:03 05-04-06 15:39
Reporter tbn View Status public  
Assigned To
Priority normal Resolution fixed  
Status closed   Product Version 3.9
Summary 0003505: Context menus in ImageBrowser (OmniBrowser) crash due to missing methods in MenuIcons
Description - use Squeak3.9#7025
- from world menu select "open..." and "ImageBrowser"
- try to open a context menu by right clicking in one of the panes (for instance class category pane)
- you get MenuIcons class(Object)>>doesNotUnderstand: #deleteIcon

Looks like there are some missing methods in MenuIcons (maybe again a merge problem)
Additional Information
Attached Files  OBIconChange-KR.cs [^] (4,029 bytes) 05-04-06 14:51

- Relationships

- Notes
(0004838 - 82 - 82 - 82 - 82 - 82 - 82)
SergeStinckwich
05-01-06 18:19

Something bad (lots of methods removal) seems to have happen during Morphic-md.90.
 
(0004854 - 206 - 221 - 221 - 221 - 221 - 221)
korakurider
05-04-06 15:08

In 7024 name of icon accessors in MenuIcons have changed
(findIcon->smallFindIcon, for instance), that break dependent codes.
If this is the way to go for 3.9, OB could cope with it by OBIconChange-KR.cs.
 
(0004857 - 10 - 10 - 10 - 10 - 10 - 10)
ducasse
05-04-06 15:39

in 39.7029
 

- Issue History
Date Modified Username Field Change
04-26-06 11:03 tbn New Issue
04-26-06 11:04 tbn Issue Monitored: tbn
05-01-06 18:19 SergeStinckwich Note Added: 0004838
05-04-06 14:51 korakurider File Added: OBIconChange-KR.cs
05-04-06 15:08 korakurider Note Added: 0004854
05-04-06 15:39 ducasse Status new => closed
05-04-06 15:39 ducasse Note Added: 0004857
05-04-06 15:39 ducasse Resolution open => fixed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
48 total queries executed.
35 unique queries executed.
Powered by Mantis Bugtracker