Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003530 [Squeak] Morphic tweak always 05-04-06 01:31 07-14-06 12:24
Reporter black View Status public  
Assigned To
Priority normal Resolution fixed  
Status closed   Product Version 3.8
Summary 0003530: SimpleSwitchMorph does not actually implement switch functionality
Description SimpleSwitchMorph does not provide an interface to turn the switch on, or off, or to toggle it, or to enquire about the state of the switch. These are elementary operations on switches.

The switch was not initialized to either of its two possible states.

Because of the way that SimpleButtonMorph class implements defaultNameStemForInstances, all subclasses of SimpleButtonMorph claimed to be buttons in the Morphic Halo.
Additional Information The changeset adds the missing methods, and tests.

I want these methods in the image so that my initial simple example used for teaching (and the book) can indeed be simple, and not have to work around these missing methods.
Attached Files  SwitchMorphEnh.2.cs [^] (3,306 bytes) 05-04-06 01:31

- Relationships

- Notes
(0005890 - 4 - 4 - 4 - 4 - 4 - 4)
MarcusDenker
07-14-06 12:24

7043
 

- Issue History
Date Modified Username Field Change
05-04-06 01:31 black New Issue
05-04-06 01:31 black File Added: SwitchMorphEnh.2.cs
07-14-06 12:24 MarcusDenker Status new => closed
07-14-06 12:24 MarcusDenker Note Added: 0005890
07-14-06 12:24 MarcusDenker Resolution open => fixed
07-14-06 12:24 MarcusDenker Fixed in Version  => 3.9


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
37 total queries executed.
30 unique queries executed.
Powered by Mantis Bugtracker