Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003538 [Squeak] Collections trivial always 05-05-06 11:20 07-14-06 12:28
Reporter Damien Cassou View Status public  
Assigned To
Priority normal Resolution fixed  
Status closed   Product Version 3.9
Summary 0003538: DictionaryTest is red (testKeyAtValue)
Description In DictionaryTest>>testKeyAtValue,

the line:
self assert: (dict keyAtValue: 1) = #c.

should become:
self assert: (dict keyAtValue: 1) = #a.

Dictionary>>#keyAtValue: returns the first key on which the value is equal to the parameter.
Additional Information
Attached Files

- Relationships

- Notes
(0004871 - 66 - 66 - 66 - 66 - 66 - 66)
ducasse
05-05-06 14:21

can you check if this test was working in 38 because I thought so.
 
(0004872 - 192 - 243 - 243 - 243 - 243 - 243)
Damien Cassou
05-05-06 14:56

This test did not exist in 3.8. But the result is correct :

dict := Dictionary new.

dict at: $a put: 1.
dict at: $b put: 2.
dict at: $c put: 1.

dict keyAtValue: 1 => $a
 
(0005893 - 26 - 26 - 26 - 26 - 26 - 26)
MarcusDenker
07-14-06 12:28

test does not fail in 7042
 

- Issue History
Date Modified Username Field Change
05-05-06 11:20 Damien Cassou New Issue
05-05-06 11:20 Damien Cassou Status new => assigned
05-05-06 11:20 Damien Cassou Assigned To  => KenCausey
05-05-06 14:21 ducasse Note Added: 0004871
05-05-06 14:56 Damien Cassou Note Added: 0004872
05-05-06 17:33 KenCausey Assigned To KenCausey =>
05-05-06 17:33 KenCausey Status assigned => new
05-05-06 17:33 KenCausey Category Any => Collections
07-14-06 12:28 MarcusDenker Status new => closed
07-14-06 12:28 MarcusDenker Note Added: 0005893
07-14-06 12:28 MarcusDenker Resolution open => fixed
07-14-06 12:28 MarcusDenker Fixed in Version  => 3.9


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
50 total queries executed.
38 unique queries executed.
Powered by Mantis Bugtracker