Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003589 [Squeak] Network minor always 05-10-06 02:25 07-14-06 16:30
Reporter Tom Koenig View Status public  
Assigned To cdegroot
Priority normal Resolution fixed  
Status closed   Product Version 3.9
Summary 0003589: [BUG][FIX] UUIDPrimitivesTest>>testCreationRandom
Description UUIDPrimitivesTest>>testCreationRandom fails on this assertion
 self should: [((UUID new at: 7) bitAnd: 16rF0) = 16r40].
As John McIntosh recommends this test is deleted since in no longer applies.
Additional Information my email to John M MacIntosh
I think you created UUID and its test case UUIDPrimitivesTest? Do you have time to help resolve the problem?

UUIDPrimitivesTest>>testCreationRandom fails on this assertion
 self should: [((UUID new at: 7) bitAnd: 16rF0) = 16r40]. Here's what I can tell you: -The failure occurs in 3.9b 7029 and in 3.8 6665 -I'm testing on win xp -the assertion appears to fail the very first time (it's in a repeats 1000)
and his response
You see originally the type of UUID generated by the operating system
would have the last twelve bytes the same since that was the bits
from the ethernet interface card. The testCreationRandom checks to
see if those bytes are the same, if not then it assumes the UUID is a
randomly generated UUID and then does a simple pass to see if there
are any duplicates in a short sequence and checks flags to see if
this is a random UUID, that as you noticed fails.

So why.

Ah, well because someone noticed that if you were tagging things with
UUIDs, a thing that I believe Microsoft office does? Then why it's
possible to determine which Windows computer generated that UUID, or
at least which ethernet card was in use at the time of editing. Since
that was a privacy concern Microsoft changed the algorithm to one-way
(right, I"m sure) hash the entire UUID.

Therefore the testCreationRandom test likely should be deleted unless
we are using the UUIDGenerator because the UUID has been hashed and
none of the should:[] are valid.

Attached Files  UUIDPrimitivesTest.tlk.1.cs.gz [^] (151 bytes) 05-10-06 02:25

- Relationships

- Notes
(0005901 - 4 - 4 - 4 - 4 - 4 - 4)
MarcusDenker
07-14-06 16:30

7044
 

- Issue History
Date Modified Username Field Change
05-10-06 02:25 Tom Koenig New Issue
05-10-06 02:25 Tom Koenig Status new => assigned
05-10-06 02:25 Tom Koenig Assigned To  => KenCausey
05-10-06 02:25 Tom Koenig File Added: UUIDPrimitivesTest.tlk.1.cs.gz
05-10-06 18:39 KenCausey Assigned To KenCausey => cdegroot
05-10-06 18:39 KenCausey Category Any => Network
07-14-06 16:30 MarcusDenker Status assigned => closed
07-14-06 16:30 MarcusDenker Note Added: 0005901
07-14-06 16:30 MarcusDenker Resolution open => fixed
07-14-06 16:30 MarcusDenker Fixed in Version  => 3.9


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
43 total queries executed.
34 unique queries executed.
Powered by Mantis Bugtracker