Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003591 [Squeak] Traits block always 05-10-06 06:33 04-18-10 21:51
Reporter korakurider View Status public  
Assigned To dvf
Priority normal Resolution unable to reproduce  
Status closed   Product Version 3.9
Summary 0003591: problems about loading legacy etoys project in 7032
Description In fresh 3.9b-7032
Loading project itself generates no error, but something is still broken:

+ Starting scripts results DNU. see squeakdebug.log attached.
  why contents of 'scripts' is smallinteger?
+ "all inst vars" in debugger for UniClass (that was shown up by above error) results another error. see squeakdebug2.log.

Additional Information
Attached Files  SqueakDebug.log [^] (3,905 bytes) 05-10-06 06:33
 SqueakDebug2.log [^] (4,471 bytes) 05-10-06 06:34

- Relationships
related to 0003386feedback MarcusDenker 3.9 can't load legacy etoys project 

- Notes
(0004898 - 123 - 123 - 123 - 123 - 123 - 123)
KenCausey
05-10-06 18:41

What project? What scripts? There is not enough information provided with this report to replicate the reported problems.
 
(0004899 - 678 - 807 - 985 - 985 - 985 - 985)
korakurider
05-11-06 03:46

I mean "project" as any etoy project created and saved by legacy squeak(e.g. squeakland ). While I tested against bunch of projets on Squeakland.org and Bob's SuperSwiki and our SuperSwiki instance in Japan and saw similar result.
Here is typical one to reproduce:
 http://www.squeakland.org/fun_projects/Sqfest_2004/stairs.005.pr [^]

How to reproduce:
 + download the project to local
 + show Project Navigator
 + Hit "Find" in navigator. open the project from FileList2
 + hit "Run" of All Scriptor tool in the project, then bung.

Or by drag&drop the project onto squeak window, it crush and emergency evaluator show up.
(Drag&drop action automatically run project)
 
(0004900 - 165 - 165 - 165 - 165 - 165 - 165)
andreas
05-11-06 06:14

Confirmed. None of the projects containing scripts will load correctly into 3.9 since traits change the metaclass structure and these projects contain (uni) classes.
 
(0013657 - 118 - 118 - 118 - 118 - 118 - 118)
laza
04-08-10 12:22

Can't find the project, but if legacy projects won't load into 3.9 we can expect them to load into 4.x? I'm saying no.
 

- Issue History
Date Modified Username Field Change
05-10-06 06:33 korakurider New Issue
05-10-06 06:33 korakurider Status new => assigned
05-10-06 06:33 korakurider Assigned To  => KenCausey
05-10-06 06:33 korakurider File Added: SqueakDebug.log
05-10-06 06:34 korakurider File Added: SqueakDebug2.log
05-10-06 18:41 KenCausey Note Added: 0004898
05-10-06 18:41 KenCausey Status assigned => feedback
05-11-06 03:46 korakurider Note Added: 0004899
05-11-06 06:14 andreas Note Added: 0004900
05-11-06 19:01 KenCausey Assigned To KenCausey => dvf
05-11-06 19:01 KenCausey Category Any => Traits
07-15-06 11:35 MarcusDenker Relationship added related to 0003386
04-08-10 12:22 laza Status feedback => resolved
04-08-10 12:22 laza Fixed in Version  => trunk
04-08-10 12:22 laza Resolution open => unable to reproduce
04-08-10 12:22 laza Note Added: 0013657
04-18-10 21:51 andreas Status resolved => closed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
66 total queries executed.
44 unique queries executed.
Powered by Mantis Bugtracker