Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000374 [Croquet] Jasmine minor always 10-14-04 02:28 10-18-04 08:05
Reporter starbow View Status public  
Assigned To andreas
Priority normal Resolution unable to reproduce  
Status resolved  
Summary 0000374: TWindow>>pointerUp: -> UndefinedObject(Object)>>doesNotUnderstand:
Description This might be a regression. In the SampleTeapot, if you click on the frame of any window, on the mouse button up, you get the following error popup. Also, the window keeps focus, so if you left click anywhere else, instead of getting the 9 control halo (what is that called?), you get the error popup.

13 October 2004 4:40:59 pm
MessageNotUnderstood: UndefinedObject>><

VM: Win32 - Squeak3.6 of '6 October 2003' [latest update: 0005424]
Image: Jasmine-rc1 [latest update: 0000057]

UndefinedObject(Object)>>doesNotUnderstand:
TWindow>>pointerUp:
TPointer>>pointerUp:
TAvatar>>selection:pointerUp:
TUserCamera>>mouseUp:
SampleTeapotMorph(TeapotMorph)>>mouseUp:
SampleTeapotMorph(Morph)>>handleMouseUp:
MouseButtonEvent>>sentTo:
SampleTeapotMorph(Morph)>>handleEvent:
SampleTeapotMorph(TeapotMorph)>>handleEvent:
SampleTeapotMorph(Morph)>>handleFocusEvent:
[] in HandMorph>>sendFocusEvent:to:clear:
PasteUpMorph>>becomeActiveDuring:
HandMorph>>sendFocusEvent:to:clear:
HandMorph>>sendEvent:focus:clear:
HandMorph>>sendMouseEvent:
HandMorph>>handleEvent:
HandMorph>>processEvents
[] in WorldState>>doOneCycleNowFor:
Array(SequenceableCollection)>>do:
WorldState>>handsDo:
WorldState>>doOneCycleNowFor:
WorldState>>doOneCycleFor:
PasteUpMorph>>doOneCycle
[] in Project class>>spawnNewProcess
[] in BlockContext>>newProcess
Additional Information
Attached Files

- Relationships

- Notes
(0000438 - 68 - 68 - 68 - 68 - 68 - 68)
andreas
10-18-04 08:05

If this is still a problem please describe exactly how to reproduce.
 

- Issue History
Date Modified Username Field Change
10-14-04 02:28 starbow New Issue
10-18-04 08:05 andreas Status new => resolved
10-18-04 08:05 andreas Resolution open => unable to reproduce
10-18-04 08:05 andreas Assigned To  => andreas
10-18-04 08:05 andreas Note Added: 0000438


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
37 total queries executed.
32 unique queries executed.
Powered by Mantis Bugtracker