Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003771 [Squeak] Morphic minor always 06-05-06 06:05 06-10-06 05:12
Reporter wiz View Status public  
Assigned To
Priority normal Resolution no change required  
Status new   Product Version
Summary 0003771: [RFI] Sometimes you need of copy of a list that just acts like editable text..
Description Sometimes you need of copy of a list that just acts like editable text.

Additional Information Pluggable lists morphs are great for selecting items from a list
 and even for deleting or adding to the list.

But suppose for documentation purposes you want to store the text copy of that list to a file. Or to make an annotated copy?

If squeak has an easy way of doing that it is too well hidden for me to find.

A simple menu item for each list that allows me to get a text copy in a workspace would be great.

The current limitation is a severe thorn-in-the-paw

Yours in service, -- Jerome Peace.

Attached Files

- Relationships

- Notes
(0005193 - 326 - 358 - 358 - 358 - 358 - 358)
ScottWallace
06-05-06 23:39

Squeak *does* have an easy way of doing that, but, indeed, it's not too easy to find:

Bring up the halo on the list-pane, and click on the red ("menu") halo handle; at the bottom of the ensuing menu you'll find "copy list to clipboard." Once you've copied the list via this command, you can paste it into a Workspace, etc.
 
(0005196 - 340 - 394 - 394 - 526 - 526 - 526)
wiz
06-06-06 08:09

Hi Scott,

I'm becoming seriously impressed by your knowledge, acuity ( for noticing this report), and speed of response.

I tried it and it seems to work at least on some lists. Omnibrowsers seem not to follow the right conventions. (reported in 0003777)


Thanks for your help and swift response.

Yours in service, -- Jerome Peace
 
(0005208 - 750 - 828 - 828 - 960 - 960 - 960)
wiz
06-08-06 06:46

On further thought...

I have looked a little further into the several lists.

-The menu item appears on some lists but not all.
-- Some of the places it appears it does not work (see error report 0003777 for omnibrowsers)
-- Some lists I'd like to see it do not have the option ( simple hierarchical lists e.g. object explorers.

Where it works it will do the job. However I am lazy and would like to have the option of just getting it into a workspace as well as the option to copy it to the clipboard.

Both options should be available to every list. And should appear readily in the list panes menus. (including the one on the scroller.)
Or in the case of explorers in the system windows menu item.

Yours in service, -- Jerome Peace
 
(0005216 - 548 - 612 - 612 - 612 - 612 - 612)
dao
06-09-06 10:41

Wiz, I suggest to split this issue into separate cases.
i.e.:
1) absence of functionality in hierarchical lists (note, that semantics in this case is not clear - for instance only "top" item names can be copied, or recursive copy of some predifined depth can be performed)
2) feature request for system windows
3) feature request for option to open directly in workspace

All three options probably are good candidates for local implementation in *your* image if you use them a lot, because others don't use them a lot.

regards,
Danil
 
(0005217 - 3251 - 3660 - 3660 - 3660 - 3660 - 3660)
wiz
06-10-06 05:12
edited on: 06-10-06 05:15

Hi Danil,

Thanks for your help. I like your suggestions.

This issue 3771 is dedicated to the story that if you have a list of any sort then you should have an (easy) way to get a text of that list. So that you can edit and annotate said text. I imagine this will be very useful for documantation.

>Wiz, I suggest to split this issue into separate cases.

>1) absence of functionality in hierarchical lists (note, that semantics in this case is not clear - for instance only "top" item names can be copied, or recursive copy of some predifined depth can be performed)

+1.

This could and should be tackled in its own issue.

The story I envisioned was that I could get a menu item
(and therefore a button) That would copy what I see in my object explorer window into workspace window.

This gives me the maximum control over what wil be presented w/o having the 'puter having to guess what I meant.

If I want to document different levels I should be able to copy, then open or close more hierarchys then copy again etc. Then cut, paste edit and annotate the texts to my hearts content.

I didn't even know how to start doing this with any list until I got Scott's clue.





2) feature request for system windows
I don't know what this refers to? Did you mean my request for the items to appear in the list panes scroll bar menu?


3) feature request for option to open directly in workspace.
Hmm. If I were implementing things I would probably implement 2 and 3 together. Becauce they would both touch the same places (methods for menus etc.) and I feel strongly about making things easy. Implementation would also probably educate the implementer as to what was really wanted.




>All three options probably are good candidates for local implementation in *your* image if you use them a lot, because others don't use them a lot.

Maybe, maybe not. Often a thing is wanted but not used because it is not easy to do. So the chicken or the egg paradox applies here.


I use mantis a lot. There is always the hope that an issue will strike the interest of someone other than myself.

Ideally they get so enthused they would go off and solve the problem themselves.

More practically, I find I am often writing notes to myself. Then as I have time to work on them embellishing on the ideas with analysis. Finally getting to a solution that pleases me.

I am a patient man. If an issue stays open on mantis with nobody noticing it but me, thats ok. I'll eventually add to it.

Having a place to put the solution on mantis means it may come to the attention of an enlighten harvester. Then I don't have to load it on top of the new current version each time one comes out.

My experience has also been that somewhere between Ideally and 'More practically' often someone is able to add a vital clue with the issue that makes a solution more findable.

Suggested action:
Leave items 2 and 3 in this issue. At least until some further work is done on them.

Maybe start a separate issue on 1).
If you feel the urge feel free to beat me to it.


Finally, Thanks again for your time and effort. Your suggestions were well worth considering.

Cheers and joy - Jerome Peace

 

- Issue History
Date Modified Username Field Change
06-05-06 06:05 wiz New Issue
06-05-06 23:39 ScottWallace Note Added: 0005193
06-05-06 23:39 ScottWallace Severity major => minor
06-05-06 23:39 ScottWallace Resolution open => no change required
06-06-06 08:09 wiz Note Added: 0005196
06-08-06 06:46 wiz Note Added: 0005208
06-09-06 10:41 dao Note Added: 0005216
06-10-06 05:12 wiz Note Added: 0005217
06-10-06 05:15 wiz Note Edited: 0005217


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
55 total queries executed.
39 unique queries executed.
Powered by Mantis Bugtracker