Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003777 [Squeak] Tools minor always 06-06-06 08:03 07-23-06 12:05
Reporter wiz View Status public  
Assigned To MarcusDenker
Priority normal Resolution fixed  
Status closed   Product Version 3.9
Summary 0003777: In 7033 In ImageBrowser (omnibrowser) copyListToClipboard menu item causes a DNU.
Description For this one
Open an ImageBrowser
Call up the halos on the package pane pluggable list. (This will take several tries till the list is honed in on.)
From red halo menu request copyListToClipboard
DNU pops up.
Additional Information The reason is the 'list' instance variable is nil.

If the same procedure is tried with a class browser the desired list is copied and can be pasted to a Workspace.

See 0003771 for why fixing this is important.
Attached Files  fixPluggableListMorph_copyListToClipboard.1.cs [^] (1,006 bytes) 06-06-06 13:58

- Relationships

- Notes
(0005197 - 194 - 266 - 266 - 266 - 266 - 266)
dao
06-06-06 13:58

Looks like direct access to list variable (when stream is being created) causes DNU.

Changing

   (String new: list size * 40)
To:
   (String new: self getList size * 40)
does the trick
 
(0005210 - 201 - 249 - 249 - 377 - 377 - 377)
wiz
06-08-06 07:49

Thanks dao

I love it when Mantis works this quickly.

Could you look at 0003771 and see if you can assist with the large quest that this is a part of?

Thanks,

Yours in service, -- Jerome Peace
 
(0006168 - 4 - 4 - 4 - 4 - 4 - 4)
MarcusDenker
07-23-06 12:05

7047
 

- Issue History
Date Modified Username Field Change
06-06-06 08:03 wiz New Issue
06-06-06 13:58 dao File Added: fixPluggableListMorph_copyListToClipboard.1.cs
06-06-06 13:58 dao Note Added: 0005197
06-08-06 07:49 wiz Note Added: 0005210
07-22-06 12:30 MarcusDenker Status new => resolved
07-22-06 12:30 MarcusDenker Resolution open => fixed
07-22-06 12:30 MarcusDenker Assigned To  => MarcusDenker
07-23-06 12:05 MarcusDenker Status resolved => closed
07-23-06 12:05 MarcusDenker Note Added: 0006168
07-23-06 12:05 MarcusDenker Fixed in Version  => 3.9


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
49 total queries executed.
37 unique queries executed.
Powered by Mantis Bugtracker