Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003877 [Squeak] Any major N/A 06-25-06 00:10 06-26-06 20:32
Reporter mathk View Status public  
Assigned To KenCausey
Priority normal Resolution duplicate  
Status closed   Product Version 3.9
Summary 0003877: SmaCCToken don't initialize start atribut correctly
Description When you inspect a RBMethodNode build like this:

-----------------------------------------
| ir ast |
ir _ IRBuilder new
       numRargs: 1;
       addTemps: #(self);
       "pushTemp: #self;"
       pushLiteral: 3;
       pushLiteral: 2;
       send: #+;
       pushLiteral: 2;
       send: #*;
       send: #factorial;
       returnTop;
       ir.

ast _ IRDecompiler new decompileIR: ir
-----------------------------------------


There is a bug when clicking on 'all inst vars'.
Additional Information You have to install the NewCompiler and all dependency befor execute the sample.
Attached Files

- Relationships
duplicate of 0003878closed  SmaCCToken don't initialize start atribut correctly 

- Notes
(0005379 - 29 - 29 - 29 - 131 - 131 - 131)
KenCausey
06-26-06 20:32

incomplete duplicate of 0003878
 

- Issue History
Date Modified Username Field Change
06-25-06 00:10 mathk New Issue
06-25-06 00:10 mathk Status new => assigned
06-25-06 00:10 mathk Assigned To  => KenCausey
06-26-06 20:31 KenCausey Relationship added duplicate of 0003878
06-26-06 20:32 KenCausey Status assigned => closed
06-26-06 20:32 KenCausey Note Added: 0005379
06-26-06 20:32 KenCausey Resolution open => duplicate


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
41 total queries executed.
32 unique queries executed.
Powered by Mantis Bugtracker