Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000388 [Croquet] Jasmine minor always 10-14-04 14:15 11-07-05 20:10
Reporter bert View Status public  
Assigned To bert
Priority normal Resolution reopened  
Status feedback  
Summary 0000388: Squeak3D.log not found on Mac
Description TGraphicsTest failed to find Squeak3D.log on a Mac. Attached fix backported from 3.7, and looks for the file in the root directory. Also, replaces 'Tea' by 'Croquet'.
Additional Information
Attached Files  GraphicsTestMac-bf.1.cs.gz [^] (2,564 bytes) 10-14-04 14:15

- Relationships

- Notes
(0000388 - 126 - 126 - 126 - 126 - 126 - 126)
johnmci
10-15-04 01:37

Didn't JMM alter the 3D mac stuff to open the log in the local directory, versus the root directory. I'm sure this is 3.7.5b3?
 
(0000389 - 192 - 192 - 192 - 192 - 192 - 192)
bert
10-15-04 01:51

He might have, but both 3.7.5b3 (which is in the Croquet download) and 3.8.2b4 (which is the latest I had) do create it in the root dir (Macintosh HD). And, did he fix the formatting. too? ;-)
 
(0000392 - 32 - 32 - 32 - 32 - 32 - 32)
bert
10-16-04 02:42

update 0063GraphicsTestMac-bf.cs
 
(0003042 - 342 - 342 - 342 - 342 - 342 - 342)
johnmci
11-07-05 20:10

3.8.9b8 has fix to set working directory to VM folder. The problem was the unix working directory was not set, so depending on how Squeak was launched the working directory could be root, which would then place Squeak3D.log there. In the XCode test environment the working directory would be set to the build directory which masked the issue.
 

- Issue History
Date Modified Username Field Change
10-14-04 14:15 bert New Issue
10-14-04 14:15 bert File Added: GraphicsTestMac-bf.1.cs.gz
10-14-04 14:15 bert Status new => acknowledged
10-14-04 14:26 bert Summary TGraphicsTest broken on Mac => Squeak3D.log not found on Mac
10-15-04 01:37 johnmci Note Added: 0000388
10-15-04 01:51 bert Note Added: 0000389
10-16-04 02:42 bert Status acknowledged => resolved
10-16-04 02:42 bert Resolution open => fixed
10-16-04 02:42 bert Assigned To  => bert
10-16-04 02:42 bert Note Added: 0000392
11-07-05 20:10 johnmci Status resolved => feedback
11-07-05 20:10 johnmci Resolution fixed => reopened
11-07-05 20:10 johnmci Note Added: 0003042


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
53 total queries executed.
37 unique queries executed.
Powered by Mantis Bugtracker