Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000400 [Croquet] Jasmine major always 10-16-04 05:06 10-19-04 09:07
Reporter rollwitz View Status public  
Assigned To andreas
Priority normal Resolution fixed  
Status resolved  
Summary 0000400: Selecting a morphic menu item inside a TWindow freezes Morphic project
Description To Reproduce:
- Go to either the car etoy window, or the chess game.
- Bring up the world menu.
- Select any item (I was trying to change projects)

TWindow will become unresponsive to your pointer, in BOTH windows.
Additional Information
Attached Files

- Relationships

- Notes
(0000432 - 512 - 546 - 546 - 546 - 546 - 546)
rollwitz
10-18-04 05:34

This is a larger problem than just the menus inside a Morphic project. To reproduce another scenario:

- Open a morphic code browser using the Croquet popup icons, bottom right icon.
- pick a method, and type in a comment, such as "comment"
- One problem is that there is no way to save this code change, because the menu to accept the change cannot be accessed. However, the big problem is that the morphic project, all TWindow halos, and the Croquet left mouse popup will now be completely unresponsive.
 
(0000433 - 45 - 45 - 45 - 45 - 45 - 45)
andreas
10-18-04 07:50

This should be fixed with the latest updates.
 
(0000470 - 645 - 719 - 719 - 719 - 719 - 719)
rollwitz
10-19-04 08:12

Andreas;

The behavior is much improved, but there is still a problem. To reproduce:

- Go to the car demo
- Pop up the World menu, and switch to the "Fun With Music" project.
- The project will come up now, this part is fixed.
- In the top left Morph, try to press the "play" button. All morphs in the project are unresponsive, and the music can't be played.

Hint: I have the old copy of Croquet, and this works fine in the old version. The morphs step, and I get music playing in the speakers. In the new version, it seems like the project may not be getting a #startStepping call, or something like that, when it needs one.
 
(0000471 - 152 - 162 - 162 - 162 - 162 - 162)
andreas
10-19-04 09:07

This should now be okay as well - the problem originated from routing the events to the previous project's hand which had some "interesting" effects ;-)
 

- Issue History
Date Modified Username Field Change
10-16-04 05:06 rollwitz New Issue
10-18-04 05:34 rollwitz Note Added: 0000432
10-18-04 07:50 andreas Status new => resolved
10-18-04 07:50 andreas Resolution open => fixed
10-18-04 07:50 andreas Assigned To  => andreas
10-18-04 07:50 andreas Note Added: 0000433
10-19-04 08:12 rollwitz Status resolved => feedback
10-19-04 08:12 rollwitz Resolution fixed => reopened
10-19-04 08:12 rollwitz Note Added: 0000470
10-19-04 09:07 andreas Status feedback => resolved
10-19-04 09:07 andreas Resolution reopened => fixed
10-19-04 09:07 andreas Note Added: 0000471


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
51 total queries executed.
36 unique queries executed.
Powered by Mantis Bugtracker