Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004178 [Squeak Packages] KomHttpServer major always 07-09-06 19:31 10-26-07 08:07
Reporter VSV View Status public  
Assigned To gcorriga
Priority normal Resolution fixed  
Status resolved  
Summary 0004178: UTF-8 input from Seaside broken
Description When running Seaside apps via WAKomEncoded on recent 3.9 images (with different Seaside versions, including the latest releases from SqueakMap and SqueakSource),
all UTF-8 inputs end up with "Internal Server Error / Error: Invalid utf8 input detected".
This happens with all used VMs under Win32 (WinXP) and Linux (non-utf8 and full-utf8 Ubuntu versions), regardless on the input conversion switches.
On 3.8 and 3.8.1 images (with Seaside2.6a3-avi.1), the inputs are OK.
Additional Information This error is thrown by the UTF8TextConverter, which gets a completely malformed (non-utf8) input.
The classic Czech testing phrase "Přli luťoučk kůň pěl ďbelsk dy" is presented as "Pli+lu?ouk+k+pl+belsk+dy" to the converter, instead of the valid utf8 variant "Příliš žluťou?ký kůň úpěl ?ábelské ódy".
The input strings look this way in 'WAKomEncoded>>convertRequest:' already, so it may be a Seaside-independant error, but as for now, i'm unable to track it any further.
Attached Files  inputConversionUTF8.txt [^] (202 bytes) 07-09-06 19:54
 CzechInputTest.st [^] (1,215 bytes) 05-04-07 15:37

- Relationships

- Notes
(0005682 - 176 - 182 - 182 - 182 - 182 - 182)
VSV
07-09-06 19:57

the Mantis form input is kind-of lacking something, cause it translates national characters to absurd links to unrelated issues.
The testing phrases are in the attached file.
 
(0006449 - 200 - 200 - 200 - 200 - 200 - 200)
VSV
08-10-06 13:57

Tested with Squeak 3.8.1-6744 with Seaside 2.6b1.lr50 on win and linux (old and new vm) and it's working OK, so i presume the error really IS in the Squeak (possibly Commanche), not in Seaside itself.
 
(0006623 - 452 - 476 - 636 - 636 - 636 - 636)
VSV
08-14-06 14:10

OK, i found there already is a solution for this problem:
WAKomEncoded doesn't work in 3.9 with utf-8 characters at all. To use accented characters (or another utf-8 based), we need to use a modified version of Seaside (Seaside2.6b1-pmm.65) with WAKomEncoded39, which works (and is already supported on seasidehosting.st).
for further explanations, read: http://www.nabble.com/Accented-characters-t1985319.html [^]

Mark this issue closed, please :)
 
(0010449 - 115 - 115 - 115 - 115 - 115 - 115)
KenCausey
03-19-07 14:53

It seems to me that to considered this closed it should be fixed in the Comanche/Kom package. Would you not agree?
 
(0010450 - 216 - 216 - 216 - 216 - 216 - 216)
pmm
03-19-07 15:05

The underlying issue is that in Squeak 3.9 the semantics of #unescapePercents have changed. I pointed out this several times on the mailing list and submitted a patch to the maintainer of Kom. Nothing happend so far.
 
(0010631 - 146 - 162 - 162 - 162 - 162 - 162)
hfm
04-30-07 07:14

FYI I've "fixed" temporarily this issue in a 3.9 (7067) image with latest VM by reverting UTF8TextConverter>>nextFromStream: to the older version.
 
(0010632 - 413 - 413 - 413 - 413 - 413 - 413)
pmm
04-30-07 08:03

Lord no! Please not again back to silently failing and just returning nil or false or assuming we don't want to decode utf-8 UTF8TextConverter. This is a curse. This makes it fucking hard to fix bugs. This is precisely why this exception was introduced. Kom is broken. If Squeak/Seaside points this out, then this is not a bug that should be fixed but a good damn useful feature. Kom needs to fixed, nothing else.
 
(0010637 - 275 - 295 - 295 - 295 - 295 - 295)
hfm
04-30-07 18:19

umm, calm down boy. have you ever read the term "hot fix"? not all here could just sit and wait others to make his work. I already knew it's NOT a correct solution, that's why I wrote "fix" and not fix. If you have a better patch, why don't post it here and make us happy :)?
 
(0010638 - 506 - 528 - 528 - 528 - 528 - 528)
pmm
04-30-07 21:03

What is broken and needs fixing is Kom. And of course I submitted patches (two methods) to the maintainer two months ago after having pointed out the problem and a fix several months earlier several times. And of course the maintainer is too busy to change one little method but of course not too busy to write plenty of mails and to do plenty of hacking on other free time projects.

Besides as mentioned above there is a "fix" in Seaside called WAKomEncoded39 which replaces WAKomEncoded in Squeak 3.9.
 
(0010640 - 301 - 323 - 323 - 323 - 323 - 323)
hfm
05-01-07 00:43

The revert to the previous version of #nextFromStream: was made because WAKomEncoded39 itself doesn't "fixed" the problem. Maybe I have to install a modified (previous?) version of Seaside (Seaside2.6b1-pmm.65?)

Is Samir Saidani the maintainer of KomHttpServer? Is he angry? What happened to Samir?
 
(0010642 - 222 - 252 - 252 - 252 - 252 - 252)
pmm
05-01-07 11:44

Can you please post extactly:
- your Seaside version
- the steps you made to reproduce the problem with WAKomEncoded39 in Squeak 3.9
and I will have a look at it.

I don't know about Samir, I sent everything to Gran.
 
(0010645 - 390 - 408 - 408 - 408 - 408 - 408)
hfm
05-02-07 06:10
edited on: 05-02-07 06:11

That was about 2 weeks ago (don't remember exactly the latest Seaside version in that time). I'm using the Squeak 3.9.2 (release) from Feb 2 2007.
The problem appeared when I triggered a component that contains a submit button with an accented character. Tell me if you can't reproduce the problem, I'll try to call my psycho and make a regression with hypnosis or something like that :)

 
(0010659 - 172 - 190 - 320 - 320 - 320 - 320)
pmm
05-04-07 15:37

I can not reproduce it, see the attached test case. Everything works fine even for Korean

You can get some nice languages from:
http://www.columbia.edu/kermit/utf8.html [^]
 
(0011368 - 79 - 85 - 85 - 85 - 85 - 85)
gcorriga
10-24-07 10:27

This should be fixed in KomHttpServer-gc.28
VSV, could you please confirm it?
 
(0011389 - 125 - 137 - 137 - 137 - 137 - 137)
gcorriga
10-26-07 08:07

This should have been fixed in the current stable release KomHttpServer-gc.29

I'm keeping the bug open for a little while.
 

- Issue History
Date Modified Username Field Change
07-09-06 19:31 VSV New Issue
07-09-06 19:31 VSV Status new => assigned
07-09-06 19:31 VSV Assigned To  => KenCausey
07-09-06 19:54 VSV File Added: inputConversionUTF8.txt
07-09-06 19:57 VSV Note Added: 0005682
07-09-06 22:26 VSV Issue Monitored: VSV
07-20-06 19:53 KenCausey Project Squeak => Squeak Packages
07-20-06 19:53 KenCausey Assigned To KenCausey =>
07-20-06 19:53 KenCausey Status assigned => new
07-20-06 19:53 KenCausey Category Any => Seaside
08-10-06 13:57 VSV Note Added: 0006449
08-14-06 14:10 VSV Note Added: 0006623
03-19-07 14:53 KenCausey Note Added: 0010449
03-19-07 14:53 KenCausey Status new => feedback
03-19-07 14:53 KenCausey Category Seaside => Comanche
03-19-07 15:05 pmm Note Added: 0010450
04-30-07 07:14 hfm Note Added: 0010631
04-30-07 08:03 pmm Note Added: 0010632
04-30-07 18:19 hfm Note Added: 0010637
04-30-07 21:03 pmm Note Added: 0010638
05-01-07 00:43 hfm Note Added: 0010640
05-01-07 11:44 pmm Note Added: 0010642
05-02-07 06:10 hfm Note Added: 0010645
05-02-07 06:11 hfm Note Edited: 0010645
05-04-07 15:37 pmm Note Added: 0010659
05-04-07 15:37 pmm File Added: CzechInputTest.st
10-23-07 17:44 KenCausey Category Comanche => KomHttpServer
10-23-07 20:53 KenCausey Status feedback => assigned
10-23-07 20:53 KenCausey Assigned To  => gcorriga
10-24-07 10:27 gcorriga Note Added: 0011368
10-26-07 08:07 gcorriga Status assigned => resolved
10-26-07 08:07 gcorriga Resolution open => fixed
10-26-07 08:07 gcorriga Note Added: 0011389


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
113 total queries executed.
63 unique queries executed.
Powered by Mantis Bugtracker