Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004258 [Squeak] Morphic minor always 07-15-06 02:53 10-18-06 14:38
Reporter wiz View Status public  
Assigned To
Priority normal Resolution fixed  
Status closed   Product Version 3.9
Summary 0004258: in 7042 SMPackage Browser appears twice in Object Tools pane.
Description For this one.

Get a fresh squeak in a new directory

From world menu get objects
  From objects select tools.

Oblserve
- Package loader displays twice, (The balloon help for each iconic button is different.)


Additional Information From the balloon help comments it is apparent that one of the buttons comes from the reqistration for flaps and I think the other is form the description for parts bin.


Other SMpackage bugs still in 7042 see:

  0003445   [Squeak]
Tools minor new 04-08-06 In 7021 SMPackageLoader is initialized with a transparent gradient. This causes unexpected color changes.
   
Attached Files  RemoveExtraSMLoader-wiz.1.cs [^] (588 bytes) 09-26-06 04:20

- Relationships
related to 0004259closed  In 7042 Opening Object's tool pane is delayed while SMpackage inits. 

- Notes
(0007377 - 397 - 432 - 432 - 432 - 432 - 432)
wiz
09-26-06 04:22

From the preamble:

This removes the description for parts bin from SMLoader class. A SMLoader is already in the tools flap because of the registerInFlapsRegistry method. Oddly the SMLoader does not appear in the tools flap.
However its version was initialized to the right size and the removed one was not. Thus the choice was made."!

SMLoader class removeSelector: #descriptionForPartsBin!
 
(0007726 - 9 - 9 - 9 - 9 - 9 - 9)
ducasse
10-18-06 14:38

in 39 RC2
 

- Issue History
Date Modified Username Field Change
07-15-06 02:53 wiz New Issue
07-15-06 11:44 MarcusDenker Relationship added related to 0004259
09-26-06 04:20 wiz File Added: RemoveExtraSMLoader-wiz.1.cs
09-26-06 04:22 wiz Note Added: 0007377
10-18-06 14:38 ducasse Status new => closed
10-18-06 14:38 ducasse Note Added: 0007726
10-18-06 14:38 ducasse Resolution open => fixed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
47 total queries executed.
35 unique queries executed.
Powered by Mantis Bugtracker