Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004278 [Croquet] Hedgehog minor always 07-18-06 17:15 12-27-06 19:50
Reporter howardstearns View Status public  
Assigned To andreas
Priority normal Resolution fixed  
Status resolved  
Summary 0004278: Image Format Testing fails on MPEG
Description Deep within the image format testing, XBMReadWriter>>understandsImageFormat gets invoked, and tries to treat the file as a UTF8 stream. It should gracefully return false for other formats (e.g., MPEG), rather than giving an error.
Additional Information Fixed with the attached file.

I'm reporting this here because Hedgehog is where I'm running into this, and because I don't know much about Squeak core source maintenance policy. Where else should I also report it? (guessing: project:Squeak category:Graphics ProductVersion:3.8 at this same Mantis site?)
Attached Files  XBMReadWriter-understandsImageFormat.st.gz [^] (465 bytes) 07-18-06 17:15

- Relationships

- Notes
(0008765 - 50 - 50 - 50 - 50 - 50 - 50)
howardstearns
12-27-06 19:50

I think this is fixed in the repository code, yes?
 

- Issue History
Date Modified Username Field Change
07-18-06 17:15 howardstearns New Issue
07-18-06 17:15 howardstearns File Added: XBMReadWriter-understandsImageFormat.st.gz
10-17-06 03:37 andreas Status new => assigned
10-17-06 03:37 andreas Assigned To  => andreas
12-27-06 19:50 howardstearns Status assigned => resolved
12-27-06 19:50 howardstearns Resolution open => fixed
12-27-06 19:50 howardstearns Note Added: 0008765


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
38 total queries executed.
30 unique queries executed.
Powered by Mantis Bugtracker