Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004350 [Squeak] Morphic minor always 07-29-06 23:06 08-10-06 11:44
Reporter wiz View Status public  
Assigned To
Priority normal Resolution fixed  
Status closed   Product Version 3.9
Summary 0004350: In 7048 Too persistant halos pop to front whenever an object is dropped.
Description
for this one
In a fresh 7048

-get a morph (I used an ellipse)
-using the halos copy the morph and resize it to be big enough to cover the smaller one and the halo that will surround it.
-surround the smaller morph with halos
- pickup the larger morph an drop it on the smaller
    so as to obscure the smaller moprh and its halos
-drop the larger morph

-observe: the halos for the smaller morph (but not the smaller morph itself
pop to the front.


Additional Information The problem of persistant halos has come up before. (Mantis 0002496).

There was a resolution for that problem that got into 7008.

It was overriden when dgd's smalland stuff was integrated later.

Since the smalland stuff also addressed the issue with a different approach I did not revisit the issue.

The answer to this bug probably lies in what's been done there.

So the two solutions deserve a better look.
Attached Files  Preferences cl...intainHalos.st [^] (247 bytes) 08-07-06 03:49

- Relationships

- Notes
(0006264 - 723 - 801 - 801 - 801 - 801 - 801)
wiz
07-30-06 00:19

Gaaahh.

I just gave a preliminary glance to the code connected with dismmising halos.

The squeak land changes have completely changed the meaning of Morph>>removeHalos and greatly increased the surface area (i.e interconnectedness of the methods and their classes.) In the process it looks like abandon all Halos has been broken.

A lot of finer points of the coding have been missed. Morph as a root class should not have the meaning of its remove morph method depend on the meaning in its subclass HandMorph.

The classes are now handling each others responsibilities. And at the preliminary glance it looks a mess and a fine mess indeed.

It will take a while to find a way to figure this out.

Arrgh.
 
(0006265 - 84 - 84 - 84 - 84 - 84 - 84)
wiz
07-30-06 00:31

Old behavior (6665 and before) is that picking up an other morph dismisses the halo.
 
(0006308 - 366 - 414 - 414 - 414 - 414 - 414)
wiz
08-03-06 01:23

Ok, I haven't fixed the bug but I've found the way to turn it off.

the old 6665 behavior can be brought back by disabling the maintain halos preference.

that controls the dismiss halos on click logis.

Since it is a small accomodation to tradition and sanity. I would suggest releasing 3dot9 with the preference disabled.

Yours in service, --Jerome Peace.
 
(0006309 - 75 - 99 - 99 - 99 - 99 - 99)
wiz
08-03-06 01:26

Reminder sent to: MarcusDenker

Hi Marcus,

For your consideration.

Yours in service, --Jerome Peace
 
(0006348 - 458 - 663 - 663 - 796 - 796 - 796)
wiz
08-07-06 03:54

Preferences cl...intainHalos.st does the trick.

'From Squeak3.9alpha of 4 July 2005 [latest update: 0007048] on 6 August 2006 at 6:11:17 pm'!

!Preferences class methodsFor: 'standard queries' stamp: 'wiz 8/6/2006 18:11'!
maintainHalos
    ^ self
        valueOfFlag: #maintainHalos
        ifAbsent: [false]! !


I just changed true to false.

I hadn't considered that you would need the change set. Thanks for the note.

Yours in service, -- Jerome Peace
 
(0006443 - 4 - 4 - 4 - 4 - 4 - 4)
MarcusDenker
08-10-06 11:44

7052
 

- Issue History
Date Modified Username Field Change
07-29-06 23:06 wiz New Issue
07-30-06 00:19 wiz Note Added: 0006264
07-30-06 00:31 wiz Note Added: 0006265
08-03-06 01:23 wiz Note Added: 0006308
08-03-06 01:26 wiz Issue Monitored: MarcusDenker
08-03-06 01:26 wiz Note Added: 0006309
08-03-06 12:44 MarcusDenker Note Added: 0006311
08-03-06 13:36 MarcusDenker Note Deleted: 0006311
08-07-06 03:49 wiz File Added: Preferences cl...intainHalos.st
08-07-06 03:54 wiz Note Added: 0006348
08-10-06 11:44 MarcusDenker Status new => closed
08-10-06 11:44 MarcusDenker Note Added: 0006443
08-10-06 11:44 MarcusDenker Resolution open => fixed
08-10-06 11:44 MarcusDenker Fixed in Version  => 3.9


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
67 total queries executed.
43 unique queries executed.
Powered by Mantis Bugtracker