Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000521 [Squeak] Morphic feature always 11-14-04 03:15 04-01-06 20:40
Reporter wiz View Status public  
Assigned To MarcusDenker
Priority normal Resolution fixed  
Status closed   Product Version
Summary 0000521: [BUG] Button properties Morph need to be fixed or removed.
Description Button properties work so poorly they are harmful to use. There is too much here IMHO to even attempt to fix.
Additional Information If there is no one actively taking responsibility for these they should be removed from the image to inspire someone to start afresh.
Attached Files  ButtonPropRemoval-wiz.1.cs [^] (944 bytes) 12-13-05 04:01

- Relationships
child of 0006530new  A mother for button, slider and menuItem targeting and argumenting related reports. 

- Notes
(0003293 - 60 - 70 - 70 - 70 - 70 - 70)
cdegroot
12-12-05 16:12

Call me stupid, but what do you mean by "button properties"?
 
(0003310 - 1226 - 1350 - 1350 - 1350 - 1350 - 1350)
wiz
12-13-05 04:00

No stupidity needed. I've been working reclusively with just the image for vocabulary. The class name is ButtonPropertiesMorph and that was what I was refering to. Its accessed from a button on the properties sheet that gets called from the recolor halo handle.


Amoung other things it has the same target setting bug that I fixed for sliders. When I started mucking around with it, thinking to fix that bug I came upon others so thick as to make me believe this class is better removed that fixed. If someone really wants something like this they are better off starting from scratch or from some other code model than this one.

---

I did eventually write a removale cs which now that you've gotten me to attend I've up loaded.

From the preamble:

"Change Set: ButtonPropRemoval-wiz
Date: 21 September 2005
Author: (wiz) Jerome Peace

This cs removes ButtonPropertiesMorph and all references to it.
It was a good idea but an unuseable execution.
Removal allows for a fresh start and cuts down on the bugs and confusion caused by having it around."!

The button proporties box is what I found so broken as to be worth getting rid of so as not to get in the way of someone making a fresh start.
 
(0004628 - 13 - 13 - 13 - 13 - 13 - 13)
MarcusDenker
03-30-06 11:58

for inclusion
 
(0004648 - 4 - 4 - 4 - 4 - 4 - 4)
MarcusDenker
04-01-06 20:40

7022
 

- Issue History
Date Modified Username Field Change
11-14-04 03:15 wiz New Issue
12-12-05 16:12 cdegroot Note Added: 0003293
12-12-05 16:12 cdegroot Status new => feedback
12-13-05 04:00 wiz Note Added: 0003310
12-13-05 04:01 wiz File Added: ButtonPropRemoval-wiz.1.cs
03-30-06 11:58 MarcusDenker Status feedback => resolved
03-30-06 11:58 MarcusDenker Fixed in Version  => 3.9
03-30-06 11:58 MarcusDenker Resolution open => fixed
03-30-06 11:58 MarcusDenker Assigned To  => MarcusDenker
03-30-06 11:58 MarcusDenker Note Added: 0004628
04-01-06 20:40 MarcusDenker Status resolved => closed
04-01-06 20:40 MarcusDenker Note Added: 0004648
06-06-07 02:36 wiz Relationship added child of 0006530


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
69 total queries executed.
51 unique queries executed.
Powered by Mantis Bugtracker