Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005243 [Squeak] Morphic minor always 10-15-06 08:28 10-18-06 14:39
Reporter tim View Status public  
Assigned To
Priority normal Resolution fixed  
Status closed   Product Version 3.9
Summary 0005243: SystemWindow>paneColor method is just disgusting
Description The SystemWindow>paneColor method is just disgusting. It has magic numbers used for the display depth. It is so badly formatted that it disguises part of the functionality.

It does magic things if the background colour is yellow or white! If the model is nil - or the model exists but is not in memory right now - it tries to use the colour of the first pane morph without any check for that being a sensible object.
Why that latter case? Why isn't using the default background colour enough in such a fallback case? Come to that, why is a pluggable text morph set to transparent?
What is supposed to happen if the Display depth is 1 - the fallback then os to use the default background colour and I see no methods that appear to do anything different for a monochrome display.
Additional Information
Attached Files

- Relationships

SYSTEM WARNING: Creating default object from empty value

related to 0003445closed tim In 3.9-7021 SMPackageLoader is initialized with a transparent gradient. This causes unexpected color changes. 
child of 0005124new  SystemWindows is ripe for a refactoring. 

- Notes
(0007690 - 66 - 66 - 66 - 154 - 154 - 154)
wiz
10-16-06 03:37

See also: 0005124 for the larger issue of refactoring SystemWindows.
 
(0007694 - 1155 - 1281 - 1281 - 1281 - 1281 - 1281)
wiz
10-16-06 07:45

Well, I think this one goes here.

In 7064 notice the color of the backgrounds (i.e. paneColor) of the three work spaces.

Open the services preference browser from the world menu.
select window color and look at what the preference says the color should be (light yellow).

From WorldMenu>open>workspace get a new workspace.
(its still gray)

To get a yellow workspace you must select the rectangle representing the color preference. Select a DIFFERENT color. Then select the original color .
Then the next time you open a system window you will get a workspace with the desired background color.

Reselecting the original color doesn't update anything. You have to change something before the system will notice that workspace has the wrong color.

I could not find a preference in services for the SMPackageLoader.

Also I noticed that on windows that do update to the proper color (e.g. transcript. The first color shown is gray then later it turns colorful.
So one of the changes I'd like to see is the color finalizaition happening before the openInWorld occurs. Probably will save time too.

Yours in service, -- Jerome Peace
 
(0007695 - 124 - 142 - 142 - 142 - 142 - 142)
wiz
10-16-06 07:53

Ha,
Workspace windows have been the wrong color since at least 3.7 was finalized and no one even noticed!

Cheers, --Jer
 
(0007727 - 8 - 8 - 8 - 8 - 8 - 8)
ducasse
10-18-06 14:39

in 39RC2
 

- Issue History
Date Modified Username Field Change
10-15-06 08:28 tim New Issue
10-15-06 08:29 tim Relationship added related to 0003445
10-16-06 03:37 wiz Note Added: 0007690
10-16-06 07:45 wiz Note Added: 0007694
10-16-06 07:53 wiz Note Added: 0007695
10-18-06 14:39 ducasse Status new => closed
10-18-06 14:39 ducasse Note Added: 0007727
10-18-06 14:39 ducasse Resolution open => fixed
09-20-07 06:03 matthewf Relationship added child of 0005124


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
58 total queries executed.
42 unique queries executed.
Powered by Mantis Bugtracker