Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005362 [Squeak] Browser major always 11-04-06 15:26 07-17-08 03:08
Reporter karl View Status public  
Assigned To
Priority normal Resolution reopened  
Status feedback   Product Version 3.9
Summary 0005362: BrowserCommentTextMorph causes way too much screen damage!
Description BrowserCommentTextMorph was added so class comments would show up in their own pane. But there is lots of invalidation of the screen between each time the pane is shown or deleted, or it's content changes. This make the update of the browser slow. You can view the screen damage by turning on Preference debugShowDamage
Additional Information
Attached Files

- Relationships

- Notes
(0008060 - 427 - 451 - 451 - 451 - 451 - 451)
karl
11-05-06 02:19

I tracked the issue down to SystemWindows>>addPaneSplitters which removes and adds pane splitters when the comment pane is added to the bottom of the browser.
I'm not sure how to fix the issue, maybe hiding and showing the pane is better than deleting and reinstalling it.
The root cause of the problem seem to be Morph>>privateAddMorph:atIndex: which do a lot of invaliditation that cause a massive redraw when it's sent.
 
(0008064 - 140 - 140 - 140 - 140 - 140 - 140)
karl
11-06-06 22:39

Ok, I think I fixed the issue. Adding morphs needed a position of the morph added otherwise the morph would be added in the top left corner.
 
(0012373 - 53 - 53 - 53 - 53 - 53 - 53)
matthewf
07-15-08 01:49

if this issue is fixed, then where is the resolution?
 
(0012386 - 386 - 440 - 440 - 440 - 440 - 440)
wiz
07-17-08 03:08

Hi Karl, Hi matthew,

It seems to me that the BrowserCommentTextMorph and its sometimes pane are the cause of more bugs than you are mentioning here.

The cost/benifit is for me to high and my general opinion it that reversion and simplification are called for.

What I don't know is how to get a general concensus to do that.


Yours in curiosity and service, --Jerome Peace
 

- Issue History
Date Modified Username Field Change
11-04-06 15:26 karl New Issue
11-05-06 02:19 karl Note Added: 0008060
11-06-06 22:39 karl Note Added: 0008064
11-06-06 22:46 KarlRamberg Status new => resolved
07-15-08 01:48 matthewf Issue Monitored: matthewf
07-15-08 01:49 matthewf Status resolved => feedback
07-15-08 01:49 matthewf Resolution open => reopened
07-15-08 01:49 matthewf Note Added: 0012373
07-17-08 03:08 wiz Note Added: 0012386


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
51 total queries executed.
37 unique queries executed.
Powered by Mantis Bugtracker