Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005402 [Squeak] VM crash always 11-12-06 04:52 12-29-07 02:53
Reporter mikevdg View Status public  
Assigned To tim
Priority normal Resolution unable to reproduce  
Status closed   Product Version 3.9
Summary 0005402: Segmentation fault in printCallStackOf
Description Well... Squeak crashed on me in the midst of debugging a Telnet application. I was working with streams... changed a bit of code in the debugger, continued and then Squeak seg faulted.

Platform: Linux (specifically Ubuntu, 5.10 I think), i386.

mikevdg@neb:~/dpon$ ./squeak -version
3.9-7 #1 Tue Jul 4 11:12:22 NZST 2006 gcc 4.0.2
Squeak3.9alpha of 4 July 2005 [latest update: 0007021]
Linux neb 2.6.12-9-386 #1 Mon Oct 10 13:14:36 BST 2005 i686 GNU/Linux
default plugin location: /home/mikevdg/squeak/vmmaker//lib/squeak/3.9-7/*.so

Image was originally the stock 3.8 image with the following loaded (available from http://www.squeaksource.com/SecureSqueak [^] and http://www.squeaksource.com/DPON: [^]

Domains-mvdg.29
DPON-mvdg.154
DPONPresentation-mvdg.3
KomServices-gk.3
MessageCapture-mvdg.9 (contains dodgy stuff like ProtoObject subclasses)
REPL-mvdg.3 (was working on this)
Muris-mvdg.6
...other "normal" packages like shout, scamper...

The VM (luckily) was built in debugging mode... I tend to make a habit of that :-). Stack trace from gdb in "additional information". Unforunately, the core is 1.1G (!! I have a 256MB machine...).

VM was built locally using latest source available from squeakvm.org/unix...somewhere.

Please ask me if you require more information: mikevdg at gulik.co.nz
Additional Information (gdb) bt
#0 0x0807a9d7 in printCallStackOf (aContext=2044749212)
    at /home/mikevdg/squeak/vmmaker/Squeak-3.9-7/platforms/unix/src/vm/interp.c:20766
#1 0x0807a97c in printCallStack ()
    at /home/mikevdg/squeak/vmmaker/Squeak-3.9-7/platforms/unix/src/vm/interp.c:20727
0000002 0x08059b72 in sigsegv (ignore=11)
    at /home/mikevdg/squeak/vmmaker/Squeak-3.9-7/platforms/unix/vm/sqUnixMain.c:637
0000003 <signal handler called>
0000004 0x0807db48 in updatePointersInRangeFromto (memStart=2044671808,
    memEnd=2045075332)
    at /home/mikevdg/squeak/vmmaker/Squeak-3.9-7/platforms/unix/src/vm/interp.c:22590
0000005 0x0806ab06 in mapPointersInObjectsFromto (memStart=4096, memEnd=65)
    at /home/mikevdg/squeak/vmmaker/Squeak-3.9-7/platforms/unix/src/vm/interp.c:10977
0000006 0x08060cc6 in incCompBody ()
    at /home/mikevdg/squeak/vmmaker/Squeak-3.9-7/platforms/unix/src/vm/interp.c:5047
0000007 0x080614ae in incrementalGC ()
    at /home/mikevdg/squeak/vmmaker/Squeak-3.9-7/platforms/unix/src/vm/interp.c:5362
---Type <return> to continue, or q <return> to quit---
0000008 0x0805c793 in allocateheaderSizeh1h2h3doFillwith (byteSize=92, hdrSize=1,
    baseHeader=240440156, classOop=2009148004, extendedSize=252, doFill=0,
    fillWord=0)
    at /home/mikevdg/squeak/vmmaker/Squeak-3.9-7/platforms/unix/src/vm/interp.c:2435
0000009 0x080622b4 in instantiateContextsizeInBytes (classPointer=77,
    sizeInBytes=1459)
    at /home/mikevdg/squeak/vmmaker/Squeak-3.9-7/platforms/unix/src/vm/interp.c:5850
0000010 0x08068c44 in interpret ()
    at /home/mikevdg/squeak/vmmaker/Squeak-3.9-7/platforms/unix/src/vm/interp.c:9753
#11 0x0805b927 in main (argc=1, argv=0xbfd0b6d4, envp=0xbfd0b6dc)
    at /home/mikevdg/squeak/vmmaker/Squeak-3.9-7/platforms/unix/vm/sqUnixMain.c:1388
Attached Files

- Relationships
child of 0006671closed tim Build VMMaker for 3.9 

- Notes
(0011061 - 35 - 35 - 35 - 35 - 35 - 35)
mikevdg
08-23-07 02:05

There's no interest in this report.
 
(0011105 - 129 - 138 - 138 - 138 - 138 - 138)
tim
09-11-07 23:32

It looks to me as if you hit the >2gb address problem -
in updatePointersInRangeFromto (memStart=2044671808, memEnd=2045075332)
 
(0011610 - 54 - 57 - 57 - 57 - 57 - 57)
tim
12-29-07 02:53

Should be fixed by fixes to the > 2Gb address problem.
 

- Issue History
Date Modified Username Field Change
11-12-06 04:52 mikevdg New Issue
08-23-07 02:05 mikevdg Note Added: 0011061
08-23-07 02:05 mikevdg Resolution open => unable to reproduce
09-11-07 23:32 tim Note Added: 0011105
09-11-07 23:33 tim Status new => assigned
09-11-07 23:33 tim Assigned To  => tim
09-14-07 00:01 tim Relationship added child of 0006671
12-29-07 02:53 tim Status assigned => closed
12-29-07 02:53 tim Note Added: 0011610
12-29-07 02:53 tim Fixed in Version  => 3.9


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
63 total queries executed.
50 unique queries executed.
Powered by Mantis Bugtracker