Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005455 [Croquet] Hedgehog minor always 11-17-06 21:37 12-04-06 07:41
Reporter howardstearns View Status public  
Assigned To howardstearns
Priority normal Resolution fixed  
Status resolved  
Summary 0005455: XRFB doesn't maintain state across sessions
Description Open a new remote desktop (e.g., to http://google.com) [^] in the KidsFirst world. Navigate to another page other than the original. Go away and come back (so that a separate sync is required). You're back at the original page. An out-of-Croquet VNC connection to the same remote display DOES see the new page.

Could be a postImport or other identity problem for embedded apps?
Additional Information Need to investigate further, but I want to get this recorded so I don't forget.

Could it be that I got something screwed up about the assignment of unique IDs (the object, the session ID, and the TForm sha) such that the late-joiner has a different session ID, causing the XRFB server to start a new session?
Attached Files

- Relationships

- Notes
(0008322 - 625 - 655 - 655 - 655 - 655 - 655)
howardstearns
11-18-06 17:22

Embedded apps are fine. The problem is peculiar to XRFB.
The appData: does not contain an objectID, but instead it is created for each new TMorphicWorld.

Meanwhile, there's some other sloppiness where, from the ocean, #makeDesktop: do one future send to make a TEmbeddedAppWithMouseOver, and another future send for name:extent:data:. So if we make the objectID there, the id is from the ocean stream on the machine that made it.

The solution to both issues is to make a specialized on-island object that does all the right stuff with the object id and can be made in-island or, with one future send, from off-island.
 
(0008533 - 25 - 25 - 25 - 25 - 25 - 25)
howardstearns
12-04-06 07:41

Fixed in Wisconsin-hrs.96
 

- Issue History
Date Modified Username Field Change
11-17-06 21:37 howardstearns New Issue
11-18-06 17:22 howardstearns Note Added: 0008322
11-28-06 04:34 howardstearns Status new => assigned
11-28-06 04:34 howardstearns Assigned To  => howardstearns
12-04-06 07:41 howardstearns Status assigned => resolved
12-04-06 07:41 howardstearns Resolution open => fixed
12-04-06 07:41 howardstearns Note Added: 0008533


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
39 total queries executed.
31 unique queries executed.
Powered by Mantis Bugtracker