Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005700 [Squeak] Collections minor always 01-03-07 21:51 09-01-08 18:08
Reporter renggli View Status public  
Assigned To
Priority normal Resolution fixed  
Status closed   Product Version 3.10
Summary 0005700: Character>>storeString
Description The store string for a wide-character (a character with its value > 255) is currently printed using the $ syntax. This is dangerous as the underlying code-stream might not encode that properly. I suggest to include the attached patch that prints wide-character using the safe form: (Character value: xxxx)
Additional Information The CharacterTest still pass.
Attached Files  Character-storeOn.st [^] (787 bytes) 01-03-07 21:52

- Relationships
related to 0004322new  aCharacter>>#storeOn: breaks Decompiler tests 

- Notes
(0008829 - 80 - 112 - 112 - 112 - 112 - 112)
Keith_Hodges
01-05-07 10:13

"fix begin"
Installer mantis bug: 5700 fix: 'Character-storeOn.st'.
"fix end"
 
(0011207 - 166 - 178 - 306 - 306 - 306 - 306)
nicolas cellier
09-25-07 20:44

While (Array with: (Character value: 1542)) storeString will use printOn: because isLiteral...

I see some relationship with http://bugs.squeak.org/view.php?id=4322 [^]
 
(0012335 - 14 - 14 - 14 - 14 - 14 - 14)
noha
07-04-08 06:23

in pharo 10049
 
(0012568 - 46 - 46 - 46 - 46 - 46 - 46)
KenCausey
09-01-08 18:08

Harvested in update 7073 released in 3.10-7159
 

- Issue History
Date Modified Username Field Change
01-03-07 21:51 renggli New Issue
01-03-07 21:52 renggli File Added: Character-storeOn.st
01-05-07 10:13 Keith_Hodges Note Added: 0008829
09-25-07 20:44 nicolas cellier Note Added: 0011207
07-04-08 06:23 noha Note Added: 0012335
09-01-08 18:08 KenCausey Status new => closed
09-01-08 18:08 KenCausey Note Added: 0012568
09-01-08 18:08 KenCausey Resolution open => fixed
09-01-08 18:08 KenCausey Fixed in Version  => 3.10
08-21-10 21:39 nicolas cellier Relationship added related to 0004322


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
57 total queries executed.
41 unique queries executed.
Powered by Mantis Bugtracker