Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006344 [Squeak] Squeak 64 bit minor always 03-14-07 14:13 04-18-10 22:06
Reporter Friedrich View Status public  
Assigned To lewis
Priority normal Resolution fixed  
Status closed   Product Version 3.8
Summary 0006344: Crash while updating SqueakMap
Description May be related to:
http://bugs.impara.de/squeak/view.php?id=5688 [^]
I got the sources for my system from
http://squeakvm.org/squeak64/dist3/ [^]

Now at least with this programs I can start squeak however if I then try to update the SqueakMap the system crashes:
Segmentation fault

1460486512 [] in ClassBuilder>update:to:
1460486696 BlockContext>ensure:
1460486144 BlockContext>valueUnpreemptively
1460485960 ClassBuilder>update:to:
1460119536 ClassBuilder>mutate:to:
1460035048 [] in ClassBuilder>recompile:from:to:mutate:
1460035232 [] in ClassBuilder>informUserDuring:
1460110744 MVCMenuMorph>informUserAt:during:
1460034496 Utilities class>informUserDuring:
1460034312 ClassBuilder>informUserDuring:
1460034128 ClassBuilder>recompile:from:to:mutate:
1460011560 ClassBuilder>name:inEnvironment:subclassOf:type:instanceVariableNames:classVariableNames:poolDictionaries:categor
1460011040 ClassBuilder>name:inEnvironment:subclassOf:type:instanceVariableNames:classVariableNames:poolDictionaries:categor
1460010688 ClassBuilder>superclass:subclass:instanceVariableNames:classVariableNames:poolDictionaries:category:
1460010504 Class>subclass:instanceVariableNames:classVariableNames:poolDictionaries:category:
1460010320 UndefinedObject>DoIt
1460004064 Compiler>evaluate:in:to:notifying:ifFail:logged:
1460003856 Compiler class>evaluate:for:notifying:logged:
1460003632 Compiler class>evaluate:for:logged:
1460003448 Compiler class>evaluate:logged:
1460004248 [] in PositionableStream>fileInAnnouncing:
1460003264 BlockContext>on:do:
1459908248 [] in PositionableStream>fileInAnnouncing:
1459911880 [] in ProgressInitiationException>defaultMorphicAction
1459911512 BlockContext>ensure:
1459909816 ProgressInitiationException>defaultMorphicAction
1459909632 ProgressInitiationException>defaultAction
1459909448 UndefinedObject>handleSignal:
1459909264 ContextPart>handleSignal:
1459909080 ContextPart>handleSignal:
1459908896 ContextPart>handleSignal:
1459908712 Exception>signal
1459908432 ProgressInitiationException>display:at:from:to:during:
1459908064 ProgressInitiationException class>display:at:from:to:during:
1459907880 AbstractString>displayProgressAt:from:to:during:
1459907632 PositionableStream>fileInAnnouncing:
1459688288 [] in MczInstaller>installMember:
1459691032 [] in MczInstaller>useNewChangeSetDuring:
1459690848 BlockContext>ensure:
1459687736 MczInstaller>useNewChangeSetDuring:
1459687304 MczInstaller>installMember:
1459688104 [] in MczInstaller>install
1459687120 OrderedCollection>do:
1459603216 MczInstaller>install
1459603032 MczInstaller class>installStream:
1459487776 [] in UndefinedObject>?
1459486896 BlockContext>ensure:
1459486712 Cursor>showWhile:
1459487256 UndefinedObject>?
1459426112 Compiler>evaluate:in:to:notifying:ifFail:logged:
1459425928 Compiler class>evaluate:for:notifying:logged:
1459425376 Compiler class>evaluate:for:logged:
1459425192 Compiler class>evaluate:logged:
1459425560 [] in PositionableStream>fileInAnnouncing:
1459425008 BlockContext>on:do:
1459418856 [] in PositionableStream>fileInAnnouncing:
1459424456 [] in ProgressInitiationException>defaultMorphicAction
1459424088 BlockContext>ensure:
1459420424 ProgressInitiationException>defaultMorphicAction
1459420240 ProgressInitiationException>defaultAction
1459420056 UndefinedObject>handleSignal:
1459419872 ContextPart>handleSignal:
1459419688 ContextPart>handleSignal:
1459419504 Exception>signal
1459419224 ProgressInitiationException>display:at:from:to:during:
1459419040 ProgressInitiationException class>display:at:from:to:during:
1459418672 AbstractString>displayProgressAt:from:to:during:
1459418424 PositionableStream>fileInAnnouncing:
1459413608 SMSqueakMap class>bootStrap
1459408680 SMSqueakMap>checkVersion:
1459408384 SMSqueakMap>loadFullFrom:
1459407304 SMSqueakMap>loadUpdatesFull:
1459407120 SMSqueakMap>loadFull
1459406888 SMSqueakMap>loadUpdates
1459407904 [] in SMLoader>loadUpdates
1459406704 BlockContext>ensure:
1459406520 Cursor>showWhile:
1459407536 [] in SMLoader>loadUpdates
1459406328 BlockContext>on:do:
1459406144 SMLoader>loadUpdates
1459405960 SMLoader>on:
1459393536 SMLoader class>newOn:
1459393352 SMLoader class>new
1459393168 SMLoader class>open
1459392800 TheWorldMenu>doMenuItem:with:
1459392616 [] in MenuItemMorph>invokeWithEvent:
1459392432 BlockContext>ensure:
1459392248 Cursor>showWhile:
1459392064 MenuItemMorph>invokeWithEvent:
1459391872 MenuItemMorph>mouseUp:
1459391688 MenuItemMorph>handleMouseUp:
1459391240 MouseButtonEvent>sentTo:
1459391056 Morph>handleEvent:
1459390872 MorphicEventDispatcher>dispatchDefault:with:
1459390688 MorphicEventDispatcher>dispatchEvent:with:
1459390504 Morph>processEvent:using:
1459390320 MorphicEventDispatcher>dispatchDefault:with:
1459390104 MorphicEventDispatcher>dispatchEvent:with:
1459389840 Morph>processEvent:using:
1459389656 Morph>processEvent:
1459389472 MenuMorph>handleFocusEvent:
1459388920 [] in HandMorph>sendFocusEvent:to:clear:
1459389104 [] in PasteUpMorph>becomeActiveDuring:
1459388736 BlockContext>on:do:
1459388552 PasteUpMorph>becomeActiveDuring:
1459388184 HandMorph>sendFocusEvent:to:clear:
1459388000 HandMorph>sendEvent:focus:clear:
1459387712 HandMorph>sendMouseEvent:
1459387528 HandMorph>handleEvent:
1459387016 HandMorph>processEvents
1459387200 [] in WorldState>doOneCycleNowFor:
1459386832 SequenceableCollection>do:
1459386648 WorldState>handsDo:
1459386464 WorldState>doOneCycleNowFor:
1459386280 WorldState>doOneCycleFor:
1459386096 PasteUpMorph>doOneCycle
1456965400 [] in Project class>spawnNewProcess
1456965768 [] in BlockContext>newProcess
Additional Information I filed int the path mentioned above however that does not change this behaviour.
Regards
Friedrich
Attached Files

- Relationships
duplicate of 0005688closed tim VM crash due to SmartSyntaxPluginCodeGenerator>>generateCPtrAsOop:indent: 

- Notes
(0013024 - 336 - 346 - 346 - 346 - 346 - 346)
lewis
03-08-09 13:46

The original "dist3" sources are quite out of date. Use the latest Subversion sources and the latest VMMaker from SqueakSource, then apply the fix in Mantis 5238. This will resolve the problem reported here. You will also need an updated 64-bit image to use with this VM (contact lewis at mail dot msen dot com if you do not have this).
 
(0013026 - 23 - 23 - 23 - 23 - 23 - 23)
lewis
03-08-09 13:47

Resolved in Mantis 5688
 

- Issue History
Date Modified Username Field Change
03-14-07 14:13 Friedrich New Issue
11-16-08 15:51 lewis Issue Monitored: lewis
03-08-09 13:38 lewis Status new => assigned
03-08-09 13:38 lewis Assigned To  => lewis
03-08-09 13:39 lewis Relationship added duplicate of 0005688
03-08-09 13:46 lewis Note Added: 0013024
03-08-09 13:47 lewis Status assigned => resolved
03-08-09 13:47 lewis Resolution open => fixed
03-08-09 13:47 lewis Note Added: 0013026
04-18-10 22:06 andreas Status resolved => closed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
50 total queries executed.
36 unique queries executed.
Powered by Mantis Bugtracker