Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006402 [Squeak] Tools block always 04-10-07 05:23 09-09-08 17:10
Reporter wiz View Status public  
Assigned To
Priority urgent Resolution fixed  
Status closed   Product Version 3.10
Summary 0006402: In 7081 Recent browser is very broken.
Description For this one:

In a fresh 7081 from the tools flap get a Recent changes browser.

problem 1:
try selecting something other than the first list item.
(selection will happen. code for selection will be displayed for about 1 second. Then selection will revert to the first list item.)
problem 1a: Try scrolling the list. after a second the reversion will happen.

problem 2

using the splitter handle try resizing the code window.

you get a debug window DNU nil>>bottomFraction.

Headache from problem number two:
 trying to get the debugger to debug doesn't work. The debug DNU keeps coming up.

Indeed nothing will proceed until the Recent changes browser is deleted.
Additional Information I got here because I was trying to find out what changed.

I usually use the changesorter to look at the changes.

[ot] The build process apparently wipes this clean. While that may be appropriate for the gamma release it seems to me wrong for the alpha releases. If you want bug trackers to track down your bugs then you've got to leave the bread crumbs in the image. At least during the alpha phase.

I tried to use the resent changes browser inplace of the change sorter for looking at what changed and ran into this bug. So until its fixed (or the changesets from the build process reappears) I'm at a loss as to how to usefully look or play with an alpha image.

And I have no idea how to track down this bug in a finite amount of time.

back to the bug:

data points from variations:

I had no problem using the window spliters on browsers proper just the recent change browser.

I had no problem using the recent change browser in 7073 so some recent change is causing the problem.

Yours in service, --Jerome Peace
Attached Files  7082fixRecentBrowser.1.cs [^] (1,311 bytes) 04-10-07 08:59
 RecentMessageSet-updateListsAndCodeIn.st [^] (534 bytes) 04-12-07 10:55
 RecentChanges.1.cs [^] (3,860 bytes) 04-13-07 04:49
 RecentChanges.2.cs [^] (3,909 bytes) 04-13-07 05:07
 RecentChanges.3.cs [^] (3,599 bytes) 05-03-07 16:48

- Relationships

SYSTEM WARNING: Creating default object from empty value

SYSTEM WARNING: Creating default object from empty value

related to 0005641pending  Cannot override default presentation of Methods in a MethodBrowser 
related to 0006691testing  Selector Browser (Method finder): unable to select a result 
child of 0007110new  Mother of Method Finder issues 

- Notes
(0010508 - 150 - 184 - 184 - 184 - 184 - 184)
wiz
04-10-07 05:27

Reminder sent to: edgardec

Hi Edgar,

I don't know how to you would say this in spanish but in english the phrase to use is "Back to the drawing board"

Cheers amigo - Jer
 
(0010509 - 699 - 757 - 757 - 757 - 757 - 757)
edgardec
04-10-07 09:10

I'm luck having a terrific bug chaser as you jerome.
What happened
I apply a enhancement what was the offender.(7075MethodBrowserImprovements.cs)
I add a regular change set for you and all could follow the problem.
This change set reverts the changed methods .
Now I convert to Monticello and publish a fake postcript cs to updates.
About having or not the history, if I don't clean , the system grows and grows with all class of garbage.
And with the forced Monticello way , I think is of poor help having it.
What could be much better is doing a "release logger" what produce a file of what real .cs was filed into the develpment image and then this info could be put in some page on wiki
 
(0010514 - 80 - 86 - 86 - 86 - 86 - 86)
edgardec
04-10-07 10:14

This now is 7082fixRecentBrowser.cs and was in updates for 3.10
Thanks Jerome !
 
(0010533 - 756 - 816 - 816 - 816 - 816 - 816)
wiz
04-12-07 23:46

Hi Edgar, Hi Keith

I have tried Edgars patch  7082fixRecentBrowser.1.cs and it does restore the recent browser to functionality (I think it is mostly just a reversion).

Keith's patch RecentMessageSet-updateListsAndCodeIn.st is just one method. Did you intend this to apply to 7081 or post 7082.

Also since the previous code broke, it is only fair to ask for tests to prove that what you (Keith) are proposing works and that the recent browser works after you are done. And that nothing else is broken.

There are a lot of methods that rely on assumptions that were changed by your upgrade. So there is a lot that can potentially go wrong. I know you are good at writing tests. So please add the effort here.

Yours in service, -Jerome Peace
 
(0010541 - 1224 - 1350 - 1350 - 1350 - 1350 - 1350)
wiz
04-14-07 02:55

Hi Keith,

1) You didn't answer the question of in what context these changes need to be added. 7081 or 7082 or ....

2) I heartily agree with your comment about the bread crumbs. I have generally used the changesorter and not the recent browser for discovering what changed.

3) I would like you to think again about the tests. The question to ask is:
If I did know what tests to make what would be the way write them?

What I did to find the scope of the changes was to chase down the ivar
that stores the string. Each of thoses methods may or may not get broken when the string is nil. And some of them may suggest tests.

The thing that got broken in the recent browser (as described in the problem description is also a candidate for testing.)

4) Partial progress counts. A start on tests. Rudimentry tests that only break if something is grossly wrong for example, are a good beginning.
Or even something that breaks before your code is added and runs afterward.

Writing the tests is part of the design experience. Ask Ralph.

I will be happy to put time in to code review when I believe you have done some due diligence in testing your work.

Yours in curiosity and service, --Jerome Peace
 
(0010544 - 564 - 648 - 648 - 648 - 648 - 648)
wiz
04-15-07 03:16
edited on: 04-16-07 18:59

Hi Keith,

Preliminary code review shows that:


RecentChanges.2.cs refers to a class ItemDragMorph that is not defined in the 7067 or even the 7081 image. The cs does not contain the class def either.

I stopped the review at this point cause things would obviously not load without errors.

1) When you make the next patch please try loading it into a fresh image before submitting it to mantis.
2) Add your initials to the cs name e.g. RecentChanges-kph.2.cs so others can be aware that it's your work before loading it.

Yours in service, -Jer

 
(0010648 - 144 - 182 - 182 - 182 - 182 - 182)
Keith_Hodges
05-03-07 16:49

"fix begin"
Installer mantis bug: 5641 fix: 'MethodBrowserImprovements.1.cs'.
Installer mantis bug: 6402 fix: 'RecentChanges.3.cs'.
"fix end"
 
(0012601 - 683 - 695 - 695 - 695 - 695 - 695)
KenCausey
09-09-08 14:16

So Jerome asks and asks and there is a sort of silence. The 7082fixRecentBrowser.1.cs was indeed harvested as 7082 and included in 3.10. It appears to have been at least a sort of fix for the issue. The issue should have been marked resolved at that point. If disagreement exists regarding the solution then a new issue should have been created clearly explaining the disagreement, including tests to clarify the difference between the status quo and the desired result.

We can't leave these issues open indefinitely hanging around from release to release with patches being thrown out in spurts. This gets to be very difficult to follow, particularly without any discussion.
 
(0012616 - 172 - 172 - 172 - 290 - 290 - 290)
KenCausey
09-09-08 17:10

I discussed this with Keith on IRC and he agreed that 0005641 covers the remainder of this issue and that this one can be closed. Harvested in update 7082, released in 3.10.
 

- Issue History
Date Modified Username Field Change
04-10-07 05:23 wiz New Issue
04-10-07 05:27 wiz Issue Monitored: edgardec
04-10-07 05:27 wiz Note Added: 0010508
04-10-07 08:59 edgardec File Added: 7082fixRecentBrowser.1.cs
04-10-07 09:10 edgardec Note Added: 0010509
04-10-07 10:14 edgardec Note Added: 0010514
04-12-07 10:55 Keith_Hodges File Added: RecentMessageSet-updateListsAndCodeIn.st
04-12-07 11:04 Keith_Hodges Note Added: 0010531
04-12-07 23:46 wiz Note Added: 0010533
04-13-07 04:49 Keith_Hodges File Added: RecentChanges.1.cs
04-13-07 05:04 Keith_Hodges Note Added: 0010534
04-13-07 05:07 Keith_Hodges File Added: RecentChanges.2.cs
04-13-07 05:09 Keith_Hodges Note Added: 0010535
04-13-07 05:10 Keith_Hodges Note Deleted: 0010535
04-13-07 05:11 Keith_Hodges Note Edited: 0010534
04-13-07 05:17 Keith_Hodges Note Added: 0010536
04-14-07 02:55 wiz Note Added: 0010541
04-14-07 02:57 wiz Status new => feedback
04-14-07 02:57 wiz Resolution open => reopened
04-15-07 03:16 wiz Note Added: 0010544
04-15-07 14:01 Keith_Hodges Note Added: 0010549
04-15-07 14:02 Keith_Hodges Note Edited: 0010549
04-15-07 14:03 Keith_Hodges Note Edited: 0010549
04-16-07 18:59 wiz Note Edited: 0010544
04-28-07 11:22 Keith_Hodges Note Edited: 0010549
04-28-07 23:16 Keith_Hodges Note Deleted: 0010531
04-28-07 23:16 Keith_Hodges Note Deleted: 0010534
04-28-07 23:16 Keith_Hodges Note Deleted: 0010536
04-28-07 23:17 Keith_Hodges Note Deleted: 0010549
05-03-07 16:48 Keith_Hodges File Added: RecentChanges.3.cs
05-03-07 16:49 Keith_Hodges Note Added: 0010648
07-17-07 16:39 wiz Relationship added parent of 0005641
09-25-07 05:32 wiz Relationship added related to 0006691
07-04-08 01:27 matthewf Relationship added child of 0007110
07-04-08 01:41 matthewf Relationship replaced related to 0005641
09-09-08 14:16 KenCausey Note Added: 0012601
09-09-08 17:10 KenCausey Status feedback => closed
09-09-08 17:10 KenCausey Note Added: 0012616
09-09-08 17:10 KenCausey Resolution reopened => fixed
09-09-08 17:10 KenCausey Fixed in Version  => 3.10


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
144 total queries executed.
60 unique queries executed.
Powered by Mantis Bugtracker