Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006518 [Squeak] Morphic major N/A 05-30-07 05:36 10-09-07 02:03
Reporter wiz View Status public  
Assigned To
Priority low Resolution duplicate  
Status closed   Product Version 3.10
Summary 0006518: [RFE] Morphic packages are too big and not properly factored. Repackaging needed.
Description This is another Mother of other reports issue.

The morphic .mcz package is a coulple megabytes on disk and still more than twice as large as other packages.

The dependencies between the classes are not well documented.

And the packages morphic and morphic extras and etoys are highly intertwined (repairing bugs often requires touching all three packages packages.)
Additional Information This report is to be the parent of other reports.

There need to be probes to
1) uncover the dependencies.
2) determine the true centers of pieces within morphic

There need to be results of those probes to generate a list of needed
repairs.

And then the repairs need to be made one by one and tests generated to guide them.

This is a report to tie the individual steps together.

Yours in curiosity and service, --Jerome Peace

Attached Files

- Relationships
duplicate of 0006593new  Whitler's Mother (Morphic ) . A parent for reports aimed at whitling the morphic package down to size 

- Notes
(0010760 - 79 - 91 - 91 - 91 - 91 - 91)
edgardec
06-02-07 11:49

I share all this view.

Maybe time to start a new Morphic Team to end of 3.10
 

- Issue History
Date Modified Username Field Change
05-30-07 05:36 wiz New Issue
06-02-07 11:49 edgardec Note Added: 0010760
08-11-07 23:08 matthewf Issue Monitored: matthewf
10-09-07 02:02 matthewf Relationship added duplicate of 0006593
10-09-07 02:03 matthewf Status new => closed
10-09-07 02:03 matthewf Resolution open => duplicate


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
42 total queries executed.
32 unique queries executed.
Powered by Mantis Bugtracker