Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006519 [Squeak] Morphic major always 05-30-07 11:28 07-03-09 00:30
Reporter kks View Status public  
Assigned To
Priority normal Resolution duplicate  
Status new   Product Version 3.9
Summary 0006519: Rotating Round Rectangle affects its color
Description In 3.10 and 3.9-7067,
 1. Pull a rounded rectangle from Supplies
 2. Duplicate and rotate it. Notice that the displayed color changes
 3. Inspect both 'color' value of both morph. They remain the same.

So it looks like rotation affects the way color is rendered.
Additional Information
Attached Files  lost-translucency.gif [^] (1,353 bytes) 05-30-07 11:28

- Relationships
duplicate of 0002241feedback  Translucent color lost when rotating a morph 

- Notes
(0010772 - 540 - 552 - 552 - 552 - 552 - 552)
kks
06-05-07 10:47

After applying the patches from 2241, I see some weird bluish artifacts within the bounds of a rotated rectangle (see alphaerror.gif). The bluish background is seen when I import the gif on Squeakland plugin, 3.9 and 3.10 using vm-3.7.7-linux-i386 or vm-3.9-10 (Croquet SDK) and Mac-vm-3.8. It is easier to see it on an LCD screen if you tilt it forward and view it at around 80 degrees. The bluish patch is not in the gif nor am I able to capture it through screenshots.

Could this be caused by roundoff errors in primitives or plugins?
 
(0013145 - 29 - 29 - 29 - 29 - 29 - 29)
KenCausey
07-03-09 00:30

keep dupes at the same status
 

- Issue History
Date Modified Username Field Change
05-30-07 11:28 kks New Issue
05-30-07 11:28 kks File Added: lost-translucency.gif
05-30-07 23:58 wiz Relationship added duplicate of 0002241
05-30-07 23:58 wiz Status new => resolved
05-30-07 23:58 wiz Resolution open => duplicate
06-05-07 10:47 kks Note Added: 0010772
07-03-09 00:30 KenCausey Note Added: 0013145
07-03-09 00:30 KenCausey Status resolved => new


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
47 total queries executed.
34 unique queries executed.
Powered by Mantis Bugtracker