Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006575 [Squeak] Traits minor always 07-23-07 09:22 11-24-08 22:42
Reporter Damien Cassou View Status public  
Assigned To dvf
Priority normal Resolution fixed  
Status closed   Product Version 3.10
Summary 0006575: New compatibility messages for TraitBehavior
Description TraitBehavior contains compatibility messages like #superclasses, #instVarNames... This helps tools to work with traits without changing everything.

The attached mcz provides:

- TraitBehavior>>#allSubclasses
- TraitBehavior>>subclasses (pushed up from TraitDescription).

Since these methods do not override anything and only returns new arrays without any computation, the fix can be considered safe.
Additional Information
Attached Files  Traits-dc.228.mcz [^] (146,896 bytes) 07-23-07 10:26

- Relationships

- Notes
(0010919 - 20 - 20 - 20 - 20 - 20 - 20)
Damien Cassou
07-23-07 10:26

Mcz is now attached.
 
(0010930 - 80 - 86 - 86 - 86 - 86 - 86)
edgardec
07-24-07 12:37

This now is 7133TraitBehavior-dc.cs and was in updates for 3.10
Thanks Damien !
 
(0012795 - 49 - 49 - 49 - 49 - 49 - 49)
KenCausey
11-24-08 22:42

Harvested as update 7133 included in Squeak 3.10.
 

- Issue History
Date Modified Username Field Change
07-23-07 09:22 Damien Cassou New Issue
07-23-07 09:22 Damien Cassou Status new => assigned
07-23-07 09:22 Damien Cassou Assigned To  => dvf
07-23-07 10:26 Damien Cassou File Added: Traits-dc.228.mcz
07-23-07 10:26 Damien Cassou Note Added: 0010919
07-24-07 12:37 edgardec Note Added: 0010930
07-25-07 22:32 Keith_Hodges Note Added: 0010937
07-25-07 22:34 Keith_Hodges Note Deleted: 0010937
11-24-08 22:42 KenCausey Status assigned => closed
11-24-08 22:42 KenCausey Note Added: 0012795
11-24-08 22:42 KenCausey Resolution open => fixed
11-24-08 22:42 KenCausey Fixed in Version  => 3.10


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
56 total queries executed.
39 unique queries executed.
Powered by Mantis Bugtracker