Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006581 [Squeak] Morphic block random 07-31-07 14:10 04-18-10 21:59
Reporter al View Status public  
Assigned To andreas
Priority high Resolution fixed  
Status closed   Product Version
Summary 0006581: Image freezes (background processes like Seaside make no progress) and Squeak hoggs CPU
Description This is the image freezing problem, where connecting with VNC and moving the mouse would bring the image alive again. When being stuck, Squeak hoggs the CPU, memory consumtion is stable.

There have been various reports matching the described symptoms, e.g., http://lists.squeakfoundation.org/pipermail/squeak-dev/2006-August/107618.html [^]
Additional Information For a detailled description and analysis of the problem refer to the Squeak-dev mailing list thread starting with message http://lists.squeakfoundation.org/pipermail/squeak-dev/2007-July/119023.html [^]
Attached Files  FreezeFix.1.cs [^] (1,460 bytes) 07-31-07 14:20

- Relationships
related to 0004882closed  VM lockup 

- Notes
(0010949 - 178 - 178 - 178 - 178 - 178 - 178)
al
07-31-07 14:24

Attached changeset adds a preference #serverMode, which, when enabled, prevents the problem. In desktop use, the preference is better disabled because of degraded UI performance.
 
(0013421 - 224 - 224 - 224 - 224 - 224 - 224)
KenCausey
12-02-09 22:00

We are using this now at source.squeak.org where we were having some trouble and at this point it seems to have helped significantly as we have had no noticeable lockups or delays since. It was installed on October 9, 2009.
 
(0013422 - 175 - 175 - 175 - 175 - 175 - 175)
KenCausey
12-02-09 22:01

Rather than harvested as is, perhaps something can be learned from this to produce a real fix that does not require distinguishing between 'server' and 'UI' or 'client' modes?
 
(0013456 - 290 - 290 - 290 - 290 - 290 - 290)
andreas
01-06-10 22:06

There's no way to fix the problem differently. The issue is that Seaside runs processes below the UI priority. If the UI takes 100% CPU there are no cycles left to serve the Seaside processes. The fix ensures that at least the UI process can't take 100% CPU by artificially waiting 50msecs.
 
(0013457 - 49 - 49 - 197 - 197 - 197 - 197)
andreas
01-06-10 22:06

http://source.squeak.org/trunk/Morphic-ar.300.mcz [^]
 

- Issue History
Date Modified Username Field Change
07-31-07 14:10 al New Issue
07-31-07 14:10 al Status new => assigned
07-31-07 14:10 al Assigned To  => KenCausey
07-31-07 14:20 al File Added: FreezeFix.1.cs
07-31-07 14:24 al Note Added: 0010949
07-31-07 14:24 al Issue Monitored: al
07-31-07 16:57 KenCausey Assigned To KenCausey =>
07-31-07 16:57 KenCausey Status assigned => new
07-31-07 16:57 KenCausey Category Any => Morphic
08-03-07 00:29 wiz Relationship added related to 0004882
12-02-09 22:00 KenCausey Note Added: 0013421
12-02-09 22:01 KenCausey Note Added: 0013422
01-06-10 22:06 andreas Note Added: 0013456
01-06-10 22:06 andreas Status new => resolved
01-06-10 22:06 andreas Resolution open => fixed
01-06-10 22:06 andreas Assigned To  => andreas
01-06-10 22:06 andreas Note Added: 0013457
04-18-10 21:59 andreas Status resolved => closed
08-26-11 11:31 lewis Issue Monitored: lewis


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
73 total queries executed.
46 unique queries executed.
Powered by Mantis Bugtracker