Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006587 [Squeak] Kernel block random 08-02-07 11:25 10-09-07 01:40
Reporter al View Status public  
Assigned To
Priority high Resolution duplicate  
Status closed   Product Version
Summary 0006587: Broken Semaphore>>critical: leads to frozen processes in Delay
Description David Shaffer: VNC doesn't respond to UI events, 0% cpu usage, several processes frozen in Delay although our Seaside server still responds.

Andreas Raab: You're missing another batch of fixes that we have long applied to our servers. In this case it's the handling of Semaphore>>critical: (which is broken in all Squeak versions).
Additional Information See mail http://lists.squeakfoundation.org/pipermail/squeak-dev/2007-July/119082.html [^] and answers to it.
Attached Files  SemaphoreCritical-ar.1.cs [^] (4,110 bytes) 08-02-07 11:25

- Relationships
duplicate of 0006588closed  Broken Semaphore>>critical: leads to frozen processes in Delay 

- Notes
(0010959 - 24 - 24 - 24 - 143 - 143 - 143)
wiz
08-03-07 13:36

exact duplicate of 0006588
 

- Issue History
Date Modified Username Field Change
08-02-07 11:25 al New Issue
08-02-07 11:25 al File Added: SemaphoreCritical-ar.1.cs
08-03-07 13:36 wiz Status new => closed
08-03-07 13:36 wiz Note Added: 0010959
08-03-07 13:36 wiz Resolution open => duplicate
10-09-07 01:39 matthewf Status closed => feedback
10-09-07 01:39 matthewf Resolution duplicate => reopened
10-09-07 01:40 matthewf Relationship added duplicate of 0006588
10-09-07 01:40 matthewf Status feedback => closed
10-09-07 01:40 matthewf Resolution reopened => duplicate


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
46 total queries executed.
32 unique queries executed.
Powered by Mantis Bugtracker