Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006625 [Squeak Packages] OmniBrowser minor always 08-15-07 13:16 01-26-08 10:27
Reporter lexspoon View Status public  
Assigned To Damien Cassou
Priority normal Resolution fixed  
Status closed  
Summary 0006625: Preferences bug: Preferences annotationEditingWindow
Description See http://bugs.squeak.org/view.php?id=6618 [^] . Made a new bug report per Ken's request.
Additional Information
Attached Files  nonStandardAnnotHelp-ls.1.cs [^] (2,627 bytes) 08-15-07 23:58

- Relationships

SYSTEM WARNING: Creating default object from empty value

SYSTEM WARNING: Creating default object from empty value

related to 0002789closed  Squeak [Enh] Annotation Preference Morph was asthetically challenged. 
related to 0001703closed  Squeak [ENH] EditableAnnotations-nk 

- Notes
(0011024 - 356 - 410 - 410 - 487 - 487 - 487)
KenCausey
08-15-07 13:27

Because I just find it confusing to have to flip over to 0006618:

Lex Spoon said:

"The root of the bug is as follows: executing "Preferences annotationEditingWindow" in a fresh 3.10 image, update 7130, causes a walkback for me. The method fails when it tries to set balloon text for "messageComesFrom", and it does not find a morph to set the text on."
 
(0011025 - 97 - 97 - 97 - 97 - 97 - 97)
KenCausey
08-15-07 13:28

I've just checked in a 7137 image and it appeared to work fine. Could you check this please Lex?
 
(0011026 - 80 - 80 - 80 - 80 - 80 - 80)
KenCausey
08-15-07 13:30

Appears this has been fixed as of 7137, awaiting confirmation from the reporter.
 
(0011027 - 345 - 367 - 367 - 367 - 367 - 367)
lexspoon
08-15-07 13:58

Good to hear.

I cannot yet confirm because running updates stops at 7130. I guess there are some pre-release updates floating around, or something? Anyway, one way or another I will try to get the newer updates and check that one of those updates fixed it. FWIW, my version of the method is by initials "wiz" and is dated February of 2006.
 
(0011028 - 601 - 637 - 741 - 741 - 741 - 741)
KenCausey
08-15-07 14:48

Hmm, that's odd. Perhaps it doesn't transition from alpha to beta? (Hmm, just checked 7130 is labelled as beta also...) At any rate you can get 7137 from http://ftp.squeak.org/3.10/ [^] . I also updated to 7141 and it still seemed fine.

The annotations for that method have not changed.

So... I decided to go ahead and download 3.10beta-7130 and see the actual error myself. Guess what, I cannot replicate it. Also, I can download updates just fine.

Lex - I think you have a bad image. Please download a fresh copy of 3.10beta7130 (or re-extract from a local pristine zip) and check again.
 
(0011030 - 944 - 1006 - 1006 - 1006 - 1006 - 1006)
lexspoon
08-16-07 00:08

Thanks for the link and for all the trials, Ken. The image I was using was gotten by updating all the way from 3.9, but it is probably better to use one of the pre-built images.

Looking further, the problem only shows up if you first load Omnibrowser-Full. Doing so causes a non-core annotation option to be added, and then the annotation editing window crashes when it tries to give a help balloon to that option. Can you or anyone verify this, that you can get a walkback by loading Omnibrowser-Full and then executing "Preferences annotationEditingWindow openInWorld" ?


I have attached a trivial patch, nonStandardAnnotHelp-ls.1.cs, that allows the window to open. It is not ideal -- it just uses "non-standard annotation" as the help -- but it is much better than the current situation.

If there are no problems, I would like this to be included. It allows Omnibrowser-Full and connectors to both be loaded at the same time.
 
(0011031 - 369 - 423 - 423 - 536 - 536 - 536)
wiz
08-16-07 03:02

Hi Scott and Ken,

I did some reseach 0002789 is where my initials came in.
I think all I did was adjust some parameters but the details are not in (my) current memory.

I also found neds mods (from bfav) which apparently did not get added but seems to muck in the same area.

Looks like lex is on the hot trail.

Yours in curiosity and service, --Jerome Peace
 
(0011032 - 155 - 155 - 155 - 155 - 155 - 155)
lexspoon
08-16-07 14:13

Hey, Jerome, thanks for the new info. Based on this info, it sounds like your patch from February 2006 did not affect the problem described in this issue.
 
(0011033 - 446 - 458 - 458 - 458 - 458 - 458)
KenCausey
08-16-07 20:40

It appears to me the that the problem is with OmniBrowserFixes-dc.24 which adds the method DefaultAnnotationInfoWithImplementor class>>initialize which adds a fifth annotation request #messageComesFrom without also updating Preferences class>>annotationInfo to provide a description. There may also be more to update as well. I believe this now comes under the category of an error in Omnibrowser and I'm going to hand it over to Damien Cassou.
 
(0011034 - 113 - 113 - 113 - 113 - 113 - 113)
KenCausey
08-16-07 20:44

Please note the above note in which I suggest this is a result of an incomplete 'fix' in OmniBrowserFixes-dc.24 .
 
(0011040 - 224 - 260 - 260 - 260 - 260 - 260)
Damien Cassou
08-20-07 11:01

Name: OmniBrowserFixes-dc.25
Author: dc
Time: 20 August 2007, 12:58:46 pm
UUID: ee3eeea6-c65b-424f-963e-153d0d22a940
Ancestors: OmniBrowserFixes-dc.24

- Overrides a method in Preferences for the annotation. Ugly hack.
 
(0011041 - 34 - 34 - 34 - 34 - 34 - 34)
Damien Cassou
08-20-07 11:01

Resolved in OmniBrowserFixes-dc.25
 

- Issue History
Date Modified Username Field Change
08-15-07 13:16 lexspoon New Issue
08-15-07 13:16 lexspoon Status new => assigned
08-15-07 13:16 lexspoon Assigned To  => KenCausey
08-15-07 13:27 KenCausey Note Added: 0011024
08-15-07 13:28 KenCausey Note Added: 0011025
08-15-07 13:30 KenCausey Status assigned => feedback
08-15-07 13:30 KenCausey Resolution open => reopened
08-15-07 13:30 KenCausey Note Added: 0011026
08-15-07 13:58 lexspoon Note Added: 0011027
08-15-07 14:48 KenCausey Note Added: 0011028
08-15-07 23:58 lexspoon File Added: nonStandardAnnotHelp-ls.1.cs
08-16-07 00:08 lexspoon Note Added: 0011030
08-16-07 02:45 wiz Relationship added related to 0002789
08-16-07 02:47 wiz Relationship added related to 0001703
08-16-07 03:02 wiz Note Added: 0011031
08-16-07 14:13 lexspoon Note Added: 0011032
08-16-07 20:40 KenCausey Note Added: 0011033
08-16-07 20:40 KenCausey Project Squeak => Squeak Packages
08-16-07 20:42 KenCausey Project Squeak Packages => Squeak
08-16-07 20:44 KenCausey Note Added: 0011034
08-16-07 20:44 KenCausey Assigned To KenCausey => Damien Cassou
08-16-07 20:44 KenCausey Status feedback => assigned
08-16-07 20:44 KenCausey Category Any => OmniBrowser
08-20-07 11:01 Damien Cassou Note Added: 0011040
08-20-07 11:01 Damien Cassou Issue Monitored: Damien Cassou
08-20-07 11:01 Damien Cassou Note Added: 0011041
08-20-07 11:01 Damien Cassou Status assigned => resolved
08-20-07 11:01 Damien Cassou Resolution reopened => fixed
08-20-07 23:56 KenCausey Project Squeak => Squeak Packages
01-26-08 10:27 Damien Cassou Status resolved => closed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
105 total queries executed.
61 unique queries executed.
Powered by Mantis Bugtracker