Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006631 [Squeak] Squeak 64 bit crash always 08-21-07 09:24 04-18-10 22:06
Reporter Friedrich View Status public  
Assigned To lewis
Priority normal Resolution fixed  
Status closed   Product Version 3.9
Summary 0006631: crash while connecting to SqueakMap
Description every time I use the SqueakMap Package Loader the system crashes. I downloaded th e newest sources from the SVN tree and compiled the stuff myself here:
the crash has the following traceback:
frido@flarge:~LD_LIBRARY_PATH% ./squeak ../Squeak3.9-final-7067.image

Segmentation fault

24103744 [] in >addressForName:timeout:
24103836 [] in Semaphore>critical:
24103468 BlockContext>ensure:
24103376 Semaphore>critical:
24102608 >addressForName:timeout:
24100496 >httpGetDocument:args:accept:request:
24100404 >httpGet:args:accept:request:
24100252 >httpGet:args:accept:
24099792 >httpGet:accept:
24099700 >httpGet:
24100068 [] in >pingServer:
24099516 BlockContext>on:do:
24099424 >pingServer:
24099976 [] in >findServer


Additional Information
Attached Files

- Relationships
duplicate of 0005688closed tim VM crash due to SmartSyntaxPluginCodeGenerator>>generateCPtrAsOop:indent: 

- Notes
(0011045 - 195 - 213 - 213 - 213 - 213 - 213)
user709
08-21-07 10:15

Ok, I downlaoded another image the final 3.9 image and whith that the connection works. So I guess it's a problem having checked out the last svn stuff which might not work.

Regards
Friedrich
 
(0011046 - 278 - 332 - 332 - 332 - 332 - 332)
user709
08-21-07 10:43

I tried to spot the problem and now I can tell.
with a 32-bit squeak I can download the things from the map
with a 64-bit squeak the crash happens usually.

So it's seems to be related to some 64-bit issues.

sorry that I can not be of more help...

Regards
Friedrich
 
(0011351 - 590 - 701 - 701 - 701 - 701 - 701)
user709
10-18-07 11:49

Ok I downloaded squeak from the subversion tree again. And I installed also the 32-bit version again. I can connet with the 32-bit squeak but if I use the same image with the 64-bit version I got:
Segmentation fault

21731576 [] in >addressForName:timeout:
21731668 [] in Semaphore>critical:
21731300 BlockContext>ensure:
21731208 Semaphore>critical:
21730440 >addressForName:timeout:
21727552 >httpGetDocument:args:accept:request:
21653892 HttpUrl>retrieveContentsArgs:accept:


The problem still persists. Does anyone have an idea why that is happening?

Regards
Friedrich
 
(0013025 - 336 - 346 - 346 - 346 - 346 - 346)
lewis
03-08-09 13:46

The original "dist3" sources are quite out of date. Use the latest Subversion sources and the latest VMMaker from SqueakSource, then apply the fix in Mantis 5238. This will resolve the problem reported here. You will also need an updated 64-bit image to use with this VM (contact lewis at mail dot msen dot com if you do not have this).
 
(0013027 - 23 - 23 - 23 - 23 - 23 - 23)
lewis
03-08-09 13:47

Resolved in Mantis 5688
 

- Issue History
Date Modified Username Field Change
08-21-07 09:24 user709 New Issue
08-21-07 10:15 user709 Note Added: 0011045
08-21-07 10:43 user709 Note Added: 0011046
10-18-07 11:49 user709 Note Added: 0011351
10-23-07 21:40 KenCausey Reporter user709 => Friedrich
03-08-09 13:38 lewis Status new => assigned
03-08-09 13:38 lewis Assigned To  => lewis
03-08-09 13:38 lewis Issue Monitored: lewis
03-08-09 13:39 lewis Relationship added duplicate of 0005688
03-08-09 13:46 lewis Note Added: 0013025
03-08-09 13:47 lewis Status assigned => resolved
03-08-09 13:47 lewis Resolution open => fixed
03-08-09 13:47 lewis Note Added: 0013027
04-18-10 22:06 andreas Status resolved => closed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
83 total queries executed.
45 unique queries executed.
Powered by Mantis Bugtracker