Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006632 [Squeak] Squeak 64 bit block always 08-21-07 09:36 11-19-07 23:54
Reporter Friedrich View Status public  
Assigned To wiz
Priority normal Resolution duplicate  
Status closed   Product Version 3.9
Summary 0006632: squeak runs into an endless loop?
Description If I type for example FileUtils pwd. and then Do It squeak goes into an infinite loop eating all the processor time it can get.

There are other situations where this happens also....

Regards
Friedrich
Additional Information
Attached Files

- Relationships
duplicate of 0006739closed tim Problems with images under 64-bit 

- Notes
(0011054 - 666 - 762 - 762 - 762 - 762 - 762)
wiz
08-22-07 01:55

Hi Frido,

Thank you for reporting the problem.

Can you make the report clearer by giving some more details.

I gather you are using a 64bit vm but which one and on what platform?

And very importantly which image are you running into the problems with.

Several time and delay bugs have been reported on mantis and included in beta stream of 3dot10. Your symptoms sound similarto the ones those fixes addressed.

The best thing for getting help is to describe a repeatable way; starting from a fresh image to run into the troubles.

Until someone else can reproduce it there is nothing to track down.

Yours in curiosity and service, --Jerome Peace
 
(0011058 - 864 - 966 - 966 - 966 - 966 - 966)
user709
08-22-07 05:51

I'm sorry for the bad report. I have not spend enough time on it and forget crucial information. so here we go:
OS: Debian/AMD 64 (unstable)
Sources from the subversion tree AFAIK it was HEAD that I checked out.
I'm currently using:
Squeak3.9-final-7067.image

I can't tell if there is a way to tell which vm is running, I just can tell it' in a subdirectory named 3.9-12 and that I have another image (32 bit !!) in
3.9-8 which does not show the problems mentioned.

Therefor I assumed it may be some 32/64 bit issue.

I hope this makes the error a bit more clear.
I can reproduce the hanging while loading from SqueakMap any non supported package (which does not have a release candidate for 3.9)

If you need more information, just let me know I'll try my best to figure them out. However I'll be out for the next two days.

Regards
Friedrich
 
(0011364 - 193 - 244 - 244 - 244 - 244 - 244)
Friedrich
10-24-07 06:10

It's debian AMD64-box. The image is the
 Squeak3.9-final-7067.image


From you message I guess one should try another image. I will see whether I can find a "newer" one.
Regards
Friedrich
 
(0011365 - 828 - 948 - 948 - 948 - 948 - 948)
wiz
10-24-07 06:52

Hi Friedrich,

Hmmm,
If you are using a fresh sq 7067 that is the most recent final image.

The other thing that would help is to report the easiest way starting from a fresh image to get into trouble.

If you think of ways that do it beside FileUtils pwd, please mention those too. Extra data points often help narrow the problem.

I am not on a 64-bit machine. And my iMac Os9.1 doesn't require me to deal with passwords.

I have discovered that infinite recursion errors are a squeak specialty and crop up in many places. Often as a result of integration problems and too many cooks.

So other things to try

Can you stop the loop with Alt-. ?

Does your image eventually run out of memory?
Do you get a low-space error log? The log may hold some clues.

Yours in curiosity and service, --Jerome Peace
 
(0011366 - 177 - 219 - 219 - 219 - 219 - 219)
wiz
10-24-07 07:00

Hmmm

In the basic sq 7067 FileUtils is not a class.
The only thing that knows pwd is FTPClient.

So your description is incomplete and I can not confirm the bug.

--Jer
 
(0011367 - 5708 - 7488 - 7874 - 8712 - 8712 - 8712)
Friedrich
10-24-07 07:38

Ok here we go again. I'm using the squeak form the subversion tree, it's version is 3.9-12. I downloaded:
sq3.9-7067dev07.10.1.zip

from:
http://damien.cassou.free.fr/squeak-dev/ [^]
Result a core dump while trying to install from Squeak map
here's backtrace from the core dump:

 gdb --core core ../3.9-12/squeak
GNU gdb 6.6.90.20070912-debian
Copyright (C) 2007 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html> [^]
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu"...
Using host libthread_db library "/lib/libthread_db.so.1".
Reading symbols from /lib/libutil.so.1...done.
Loaded symbols for /lib/libutil.so.1
Reading symbols from /lib/libdl.so.2...done.
Loaded symbols for /lib/libdl.so.2
Reading symbols from /lib/libm.so.6...done.
Loaded symbols for /lib/libm.so.6
Reading symbols from /lib/libnsl.so.1...done.
Loaded symbols for /lib/libnsl.so.1
Reading symbols from /lib/libc.so.6...done.
Loaded symbols for /lib/libc.so.6
Reading symbols from /lib/ld-linux-x86-64.so.2...done.
Loaded symbols for /lib64/ld-linux-x86-64.so.2
Core was generated by `../3.9-12/squeak sq3.9-7067dev07.10.1.image'.
Program terminated with signal 11, Segmentation fault.
#0 0x00002b311a95e73d in ?? () from /lib64/ld-linux-x86-64.so.2
(gdb) bt
#0 0x00002b311a95e73d in ?? () from /lib64/ld-linux-x86-64.so.2
#1 0x00002b311a95ebef in ?? () from /lib64/ld-linux-x86-64.so.2
0000002 0x00002b311a962864 in ?? () from /lib64/ld-linux-x86-64.so.2
0000003 0x00002b311a968a52 in ?? () from /lib64/ld-linux-x86-64.so.2
0000004 0x00000000004179fe in sigsegv (ignore=<value optimized out>)
    at /usr/local/src/Smalltalk/squeak-svn/platforms/unix/vm/sqUnixMain.c:650
0000005 <signal handler called>
0000006 0x00002b311b48f97e in memcpy () from /lib/libc.so.6
0000007 0x00000000004aabdf in sqResolverStartNameLookup (
    hostName=0x2b311e445248 "", nameSize=<value optimized out>)
    at /usr/local/src/Smalltalk/squeak-svn/platforms/unix/plugins/SocketPlugin/sqUnixSocket.c:1441
0000008 0x00000000004a62a7 in primitiveResolverStartNameLookup ()
    at /usr/local/src/Smalltalk/squeak-svn/platforms/unix/src/vm/intplugins/SocketPlugin/SocketPlugin.c:629
0000009 0x0000000000419ee6 in dispatchFunctionPointer (aFunctionPointer=0x764fe0)
    at /usr/local/src/Smalltalk/squeak-svn/platforms/unix/src/vm/interp.c:3868
0000010 0x0000000000419ee6 in dispatchFunctionPointer (aFunctionPointer=0x764fe0)
    at /usr/local/src/Smalltalk/squeak-svn/platforms/unix/src/vm/interp.c:3868
#11 0x000000000042d6fe in interpret ()
    at /usr/local/src/Smalltalk/squeak-svn/platforms/unix/src/vm/interp.c:7673
0000012 0x00000000004186ae in main (argc=<value optimized out>,
    argv=0x7fff901519f8, envp=<value optimized out>)
---Type <return> to continue, or q <return> to quit---
    at /usr/local/src/Smalltalk/squeak-svn/platforms/unix/vm/sqUnixMain.c:1407
(gdb)
(gdb)

Then I downloaded Squeak3.10beta.7158.zip from
http://ftp.squeak.org/current_development/ [^]

I can start the image like this:
./3.9-12/squeak Squeak3.10beta.7158.image
But when I open the Package Browser I get:
MessageNotUnderstood: String class>>numbers
String class(Object)>>doesNotUnderstand: #numbers
VersionNumber>>=
SmartRefStream(DataStream)>>next
SmartRefStream(ReferenceStream)>>next
SmartRefStream>>next
Association(Object)>>readDataFrom:size:
SmartRefStream>>readInstanceSize:clsname:refPosn:
SmartRefStream>>readShortInst
SmartRefStream(DataStream)>>next
SmartRefStream(ReferenceStream)>>next
SmartRefStream>>next
SmartRefStream(DataStream)>>readArray
SmartRefStream(DataStream)>>next
SmartRefStream(ReferenceStream)>>next
SmartRefStream>>next
SmartRefStream(DataStream)>>readArray
SmartRefStream(DataStream)>>next
SmartRefStream(ReferenceStream)>>next
SmartRefStream>>next
OrderedCollection(Object)>>readDataFrom:size:

String class(Object)>>doesNotUnderstand: #numbers
VersionNumber>>=
SmartRefStream(DataStream)>>next
SmartRefStream(ReferenceStream)>>next
SmartRefStream>>next
Association(Object)>>readDataFrom:size:
SmartRefStream>>readInstanceSize:clsname:refPosn:
SmartRefStream>>readShortInst
SmartRefStream(DataStream)>>next
SmartRefStream(ReferenceStream)>>next
SmartRefStream>>next
SmartRefStream(DataStream)>>readArray
SmartRefStream(DataStream)>>next
SmartRefStream(ReferenceStream)>>next
SmartRefStream>>next
SmartRefStream(DataStream)>>readArray
SmartRefStream(DataStream)>>next
SmartRefStream(ReferenceStream)>>next
SmartRefStream>>next
OrderedCollection(Object)>>readDataFrom:size:
doesNotUnderstand: aMessage
     "Handle the fact that there was an attempt to send the given message to the receiver but the receiver does not understand this message (typically sent from the machine when a message is sent to the receiver and no method is defined for that selector)."
    "Testing: (3 activeProcess)"

    MessageNotUnderstood new
        message: aMessage;
        receiver: self;
        signal.
    ^ aMessage sentTo: self.

Proceed
Restart
Into
Over
Through
Full Stack
Where
Tally
self
all inst vars
superclass
methodDict
format
instanceVariables
organization
subclasses
name
classPool
sharedPools
environment
category
traitComposition
localSelectors

self
all inst vars
superclass
methodDict
format
instanceVariables
organization
subclasses
name
classPool
sharedPools
environment
category
traitComposition
localSelectors

thisContext
all temp vars
aMessage

thisContext
all temp vars
aMessage

Regards
Friedrich
 
(0011369 - 328 - 388 - 516 - 516 - 516 - 516)
Friedrich
10-24-07 11:00

Ah well I think this should be filed
under
http://bugs.squeak.org/view.php?id=6631 [^]

Yes you are right there is not FileUtil pwd in the image that was a much older one 3.8 IIRC.

Sorry for filing that up here. However I still insist that there are trouble on
AMD64/Debian machines with a 64-bit VM.

Regards
Friedrich
 
(0011378 - 967 - 1087 - 1087 - 1087 - 1087 - 1087)
wiz
10-25-07 01:37

Hi Friedrich,

>Sorry for filing that up here.

>However I still insist that there are trouble on
AMD64/Debian machines with a 64-bit VM.

How do you know? From what you have described here. And the way you have had a problem telling the wheat from the chaff. I don't see how you can know if the problem is because of the VM and the AMD64/Debian or a problem with the squeak image proper.

You still have not supplied a formula for recreating the problem.

Sloppy description here just wastes peoples time.

As far as I concerned this report is pretty well fubar and my recommendation is that it be closed.

If you should have the problem again I suggest you start fresh and file another report with proper observations.

Or that we leave this (or the next) report in you hands until you both diagnose and solve the problem (and at this point I would insist on tests that prove it is solved.) .

Yours in curiosity and service, --Jerome Peace
 
(0011380 - 236 - 266 - 266 - 266 - 266 - 266)
Friedrich
10-25-07 05:40

You are right. And I apologice but that does not change the fact that there is a problem. It's easy to reproduce but I will file another bug report. And it will be clear.

As said I'm sorry for wasting your time.

Regards
Friedrich
 
(0011385 - 169 - 197 - 197 - 197 - 197 - 197)
Friedrich
10-26-07 05:31

Well you were right with critizising me. But bug reports from August are still "unasssigned" and have not give any feedback. Is that the right way?

Regards
Friedrich
 
(0011391 - 1452 - 1588 - 1706 - 1706 - 1706 - 1706)
wiz
10-26-07 17:49

HI Friedrich ,

[OT] I appreciate that you are trying to solve a problem and that you choose to write a mantis report to do it.

Technically you have not wasted my time. Only I can do that. And I haven't here. I am learning how to train good mantis reporters.

If I succeed with you, you will become one. If I fail, I'll have learned another thing I need to know for another person the next time. See the Mantis Faqs on the swiki:

http://wiki.squeak.org/squeak/5912 [^]

>But bug reports from August are still "unasssigned" and have not give any feedback.
>Is that the right way?

It is the way it is, This is a volunteer community and no one assigns themselves to feedback or fixing a bug unless they have a personal interest in doing so. If I put a report on mantis I expect to be the one to provide analysis and eventually a solution. My hope is always that someone else will find the report interesting and chime in with a clue or a fix. As mantis gets more use. As the community realizes its value. Those two boons happen more and more often.

A well written report that can be followed up on is more likely to attract help and comments. That's why I am so interested in getting those who are willing to try mantis to the point where they can succeed in getting what they need from it.

----
So write a GOOD report. Then ask for help from the list and point to the bug report so people can find it.

Cheers and good luck, -Jer
 
(0011393 - 317 - 365 - 621 - 621 - 621 - 621)
Friedrich
10-27-07 07:27

Ok then I just like to know what unclear about the following bug reports:
http://bugs.squeak.org/view.php?id=6739 [^]

or
http://bugs.squeak.org/view.php?id=6631 [^]

It's reproducable and I guess it's not that bad a bug report as the one I've written here. I messed that up and that was my fault...
Regards
Friedrich
 

- Issue History
Date Modified Username Field Change
08-21-07 09:36 user709 New Issue
08-22-07 01:55 wiz Note Added: 0011054
08-22-07 05:51 user709 Note Added: 0011058
10-23-07 21:39 KenCausey Reporter user709 => Friedrich
10-24-07 06:10 Friedrich Note Added: 0011364
10-24-07 06:52 wiz Note Added: 0011365
10-24-07 07:00 wiz Note Added: 0011366
10-24-07 07:38 Friedrich Note Added: 0011367
10-24-07 11:00 Friedrich Note Added: 0011369
10-25-07 01:37 wiz Note Added: 0011378
10-25-07 01:37 wiz Status new => resolved
10-25-07 01:37 wiz Resolution open => unable to reproduce
10-25-07 01:37 wiz Assigned To  => wiz
10-25-07 05:40 Friedrich Note Added: 0011380
10-26-07 05:31 Friedrich Note Added: 0011385
10-26-07 17:49 wiz Note Added: 0011391
10-27-07 07:27 Friedrich Note Added: 0011393
10-28-07 02:05 wiz Relationship added related to 0006739
11-19-07 23:54 matthewf Status resolved => closed
11-19-07 23:54 matthewf Resolution unable to reproduce => duplicate
11-19-07 23:55 matthewf Relationship replaced duplicate of 0006739


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
114 total queries executed.
72 unique queries executed.
Powered by Mantis Bugtracker