Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006657 [Squeak Packages] OmniBrowser minor always 09-03-07 12:44 01-29-08 19:07
Reporter Damien Cassou View Status public  
Assigned To cwp
Priority normal Resolution no change required  
Status resolved  
Summary 0006657: There is no way of retrieving what is selected from the OBDefinition of OBDefinitionPanel
Description Even if you can ask the OBPluggableTextMorph instance his #selectionNode, there is no way of getting this value from an OBDefinition or OBDefinitionPanel. Methods like #selection or #textSelection always returns (1 to: 0).
Additional Information
Attached Files

- Relationships

- Notes
(0011650 - 749 - 755 - 755 - 755 - 755 - 755)
dr
01-09-08 13:32

I agree that it makes sense to ask the OBDefinitionPanel for the selected node in some situations. I implemented this possibility for the OB-Enhancement package in a subclass of OBDefinitionPanel. I could backport this to the general OBDefinitionPanel class.
However, I think OBDefinition should not know the selected node by default. When a specific definition, eg. the method definition or the class definition has to know the method or class, then it should get passed to it. But I'm not sure if it's a good idea to make any definition aware of the selected node, because this knowledge is not needed by most definitions. And for those that do need the information, it make sense to pass it to them by using dedicated subclasses of OBDefinition.
 
(0011652 - 95 - 95 - 95 - 95 - 95 - 95)
Damien Cassou
01-09-08 13:36

I agree with you. I've sent a mail to ob-dev about this. We will see if I can close the report.
 
(0011718 - 20 - 20 - 20 - 20 - 20 - 20)
Damien Cassou
01-26-08 14:45

What about this bug?
 
(0011726 - 220 - 220 - 220 - 220 - 220 - 220)
cwp
01-29-08 19:06

I think David is right. Another option for the cases where you do want to know about the current node, and be notified when it changes is to create a custom subclass of OBPanel, and use that instead of OBDefinitionPanel.
 

- Issue History
Date Modified Username Field Change
09-03-07 12:44 Damien Cassou New Issue
09-03-07 12:44 Damien Cassou Status new => assigned
09-03-07 12:44 Damien Cassou Assigned To  => Damien Cassou
01-09-08 13:32 dr Note Added: 0011650
01-09-08 13:36 Damien Cassou Note Added: 0011652
01-26-08 14:45 Damien Cassou Note Added: 0011718
01-26-08 14:45 Damien Cassou Assigned To Damien Cassou => cwp
01-26-08 14:45 Damien Cassou Status assigned => feedback
01-29-08 19:06 cwp Note Added: 0011726
01-29-08 19:07 cwp Status feedback => resolved
01-29-08 19:07 cwp Resolution open => no change required


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
51 total queries executed.
37 unique queries executed.
Powered by Mantis Bugtracker