Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006687 [Squeak] Morphic tweak always 09-19-07 19:48 10-09-07 23:19
Reporter matthewf View Status public  
Assigned To matthewf
Priority normal Resolution fixed  
Status assigned   Product Version
Summary 0006687: MenuMorphs are too easy to pick up
Description When trying to select a menu item, it is very easy to accidentally grab the entire menu, requiring an extra click to put down the menu, and another click to select what you wanted to do in the first place
Additional Information
Attached Files  MenuMorph-ungrabbable.mtf.1.cs [^] (5,307 bytes) 09-19-07 19:50
 MenuMorph-BetterMouseHandling.1.cs [^] (6,117 bytes) 09-20-07 12:45
 MenuMorph-BetterMouseHandling.2.cs [^] (3,518 bytes) 10-09-07 23:10

- Relationships

SYSTEM WARNING: Creating default object from empty value

SYSTEM WARNING: Creating default object from empty value

SYSTEM WARNING: Creating default object from empty value

related to 0001780pending matthewf Stay up menus have a confusing and dangerous behavior when obscured. 
related to 0005608closed matthewf preference #menuTitleBorderWidth - MenuMorph bugfix 
child of 0006635new  Mother of Squeak UI annoyances 
child of 0006530new  A mother for button, slider and menuItem targeting and argumenting related reports. 

- Notes
(0011154 - 228 - 252 - 252 - 252 - 252 - 252)
matthewf
09-19-07 19:52

uploaded a patch. This makes grabbing a menu only possible from the title bar of the menu. Menus without a title bar cannot be grabbed.

I uploaded in two forms:
- a simple change set
- a set of overrides in PinesoftWidgets
 
(0011155 - 365 - 401 - 401 - 401 - 401 - 401)
matthewf
09-19-07 20:09

Specifically, the various ways to (accidently) grab a menu:
- clicking along the top/bottom/left/right edge
- clicking on a separator between menu items
- clicking the keyboard search text at the bottom of the menu
- clicking the inset box in the menu title

The two uploaded patches only let a menu be grabbed by the last method (or, by the halos, of course)
 
(0011156 - 88 - 88 - 88 - 88 - 88 - 88)
matthewf
09-20-07 01:22

Uploaded a morphic snapshot for 3.10. Based on the latest morphic in the 3.10 repository
 
(0011164 - 123 - 123 - 123 - 243 - 243 - 243)
wiz
09-20-07 03:58

The behavior you describe will interact with the behavior described in 0001780. Both should probably be fix at the same time.
 
(0011168 - 104 - 116 - 116 - 116 - 116 - 116)
matthewf
09-20-07 05:33
edited on: 09-20-07 05:39

I proposed a hack of a solution to 0001780, and it does not conflict with the current fix for this bug

 
(0011170 - 223 - 223 - 223 - 343 - 343 - 343)
matthewf
09-20-07 12:48

On looking a second time, this fix does interact with 0001780; with both loaded, the menu is not raised when clicking on the edge of the menu or a seperator. Uploaded MenuMorph-BetterMouseHandling that fixes both bugs at once
 
(0011276 - 222 - 228 - 228 - 432 - 432 - 432)
matthewf
10-09-07 23:14

Added the fix for 0005608 to MenuMorph-BetterMouseHandling.2.cs, since 0005608 was added to the 3.10 update stream, and this change interferes with that one (both modify MenuMorph>>addTitle:icon:updatingSelector:updateTarget:)
 

- Issue History
Date Modified Username Field Change
09-19-07 19:48 matthewf New Issue
09-19-07 19:49 matthewf Relationship added child of 0006530
09-19-07 19:50 matthewf File Added: MenuMorph-ungrabbable.mtf.1.cs
09-19-07 19:50 matthewf File Added: Pinesoft-Widgets-mtf.239.mcz
09-19-07 19:52 matthewf Note Added: 0011154
09-19-07 19:52 matthewf Relationship deleted child of 0006530
09-19-07 19:52 matthewf Relationship added child of 0006635
09-19-07 20:09 matthewf Note Added: 0011155
09-20-07 01:20 matthewf File Added: Morphic-mtf.130.mcz
09-20-07 01:22 matthewf Note Added: 0011156
09-20-07 03:52 wiz Relationship added related to 0001780
09-20-07 03:58 wiz Note Added: 0011164
09-20-07 05:31 matthewf Status new => assigned
09-20-07 05:31 matthewf Assigned To  => matthewf
09-20-07 05:33 matthewf Note Added: 0011168
09-20-07 05:39 matthewf Note Edited: 0011168
09-20-07 12:45 matthewf File Added: MenuMorph-BetterMouseHandling.1.cs
09-20-07 12:48 matthewf Note Added: 0011170
10-07-07 21:14 matthewf Relationship added child of 0006530
10-09-07 22:37 matthewf Relationship added related to 0005608
10-09-07 23:10 matthewf File Added: MenuMorph-BetterMouseHandling.2.cs
10-09-07 23:11 matthewf File Deleted: Morphic-mtf.130.mcz
10-09-07 23:11 matthewf File Deleted: Pinesoft-Widgets-mtf.239.mcz
10-09-07 23:14 matthewf Note Added: 0011276
10-09-07 23:19 matthewf Resolution open => fixed
11-24-07 15:00 matthewf Issue Monitored: matthewf


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
111 total queries executed.
62 unique queries executed.
Powered by Mantis Bugtracker