Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006696 [Squeak] Kernel minor always 09-24-07 23:45 10-03-09 19:34
Reporter nicolas cellier View Status public  
Assigned To andreas
Priority normal Resolution fixed  
Status assigned   Product Version 3.10
Summary 0006696: ScaledDecimal can read in base 16 but cannot print in base 16
Description (20.0s1 printStringBase: 16) raise a debugger
'My subclass should have overridden #printOn:base:'
Additional Information
Attached Files  ScaledDecimalPrintStringBase-M6696-Test.2.cs [^] (803 bytes) 09-24-07 23:56

- Relationships

SYSTEM WARNING: Creating default object from empty value

SYSTEM WARNING: Creating default object from empty value

SYSTEM WARNING: Creating default object from empty value

SYSTEM WARNING: Creating default object from empty value

SYSTEM WARNING: Creating default object from empty value

SYSTEM WARNING: Creating default object from empty value

related to 0006482closed andreas [BUG] Interval storeOn: incorrect for some ScaledDecimal 
related to 0004378closed andreas ScaledDecimal storeString incorrectly use printOn: and loose exactness 
related to 0005693new  ScaledDecimal printString truncates rather than rounds, giving some surprising results. 
related to 0006697closed andreas Number>>storeOn:base: default implementation is wrong 
related to 0003493new  printing a float in base 16 is broken sometimes 

- Notes
(0011194 - 133 - 157 - 541 - 541 - 541 - 541)
nicolas cellier
09-24-07 23:47

see also

http://bugs.squeak.org/view.php?id=4378 [^]
http://bugs.squeak.org/view.php?id=5693 [^]
http://bugs.squeak.org/view.php?id=6482 [^]
 
(0011195 - 141 - 141 - 141 - 141 - 141 - 141)
nicolas cellier
09-24-07 23:58

Please someone delete ScaledDecimalPrintStringBase-M6696-Test.1.cs (wrong manipulations in the Browser because of unresponsive Squeak image!)
 
(0011196 - 717 - 787 - 787 - 787 - 787 - 787)
nicolas cellier
09-25-07 00:07

The tests has been written as if printing in another base makes sense.
However, I am not sure it does.

The intention of the class is to print a number of digits in base 10 after the decimal point.
What would it mean in another base? Should it print with same number of digits, or with a number of digits leading to equivalent precision?

Maybe a self shouldNotImplement would make sense.
Alternatively all the base stuff in Number could be removed too (it is either re-defined or irrelevant in subclasses)

On the other hand, different radix are allowed on input as 16r14.0s1, so what?
Should the radix used to input the number be an instVar (this number keep n digits after the "decimal" point in base r).
 
(0011198 - 125 - 131 - 259 - 259 - 259 - 259)
nicolas cellier
09-25-07 00:33

If ever corrected, then both printOn:base: AND storeOn:base: need being defined.
See http://bugs.squeak.org/view.php?id=6697 [^]
 
(0011565 - 117 - 176 - 176 - 176 - 176 - 176)
Keith_Hodges
12-17-07 17:23

"fix begin"
 
"fix test"
Installer mantis bug: 6696 fix:'ScaledDecimalPrintStringBase-M6696-Test.2.cs'.
"fix end"
 

- Issue History
Date Modified Username Field Change
09-24-07 23:45 nicolas cellier New Issue
09-24-07 23:47 nicolas cellier Note Added: 0011194
09-24-07 23:50 nicolas cellier File Added: ScaledDecimalPrintStringBase-M6696-Test.1.cs
09-24-07 23:53 nicolas cellier Issue Monitored: nicolas cellier
09-24-07 23:53 nicolas cellier Issue End Monitor: nicolas cellier
09-24-07 23:56 nicolas cellier File Added: ScaledDecimalPrintStringBase-M6696-Test.2.cs
09-24-07 23:58 nicolas cellier Note Added: 0011195
09-25-07 00:07 nicolas cellier Note Added: 0011196
09-25-07 00:33 nicolas cellier Note Added: 0011198
09-25-07 01:16 matthewf Relationship added related to 0003493
09-25-07 01:19 matthewf Relationship added related to 0006482
09-25-07 01:19 matthewf Relationship added related to 0004378
09-25-07 01:20 matthewf Relationship added related to 0005693
09-25-07 01:20 matthewf Relationship added related to 0006697
12-17-07 17:23 Keith_Hodges Note Added: 0011565
01-10-09 02:00 Keith_Hodges Status new => pending
01-10-09 03:31 Keith_Hodges Status pending => testing
01-10-09 03:39 Keith_Hodges Status testing => resolved
01-10-09 03:39 Keith_Hodges Fixed in Version  => 3.11
01-10-09 03:39 Keith_Hodges Resolution open => fixed
01-10-09 03:39 Keith_Hodges Assigned To  => Keith_Hodges
01-10-09 03:41 Keith_Hodges Status resolved => testing
10-03-09 19:34 Keith_Hodges Status testing => assigned
10-03-09 19:34 Keith_Hodges Assigned To Keith_Hodges => andreas
10-04-09 17:58 nicolas cellier File Deleted: ScaledDecimalPrintStringBase-M6696-Test.1.cs


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
90 total queries executed.
51 unique queries executed.
Powered by Mantis Bugtracker