Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006698 [Squeak] Collections tweak always 09-25-07 20:51 01-02-13 23:19
Reporter wiz View Status public  
Assigned To
Priority normal Resolution fixed  
Status closed   Product Version 3.10
Summary 0006698: #assertSlopesWith:from:to: in SeqColl needs to be removed
Description From Nicolas:
http://lists.squeakfoundation.org/pipermail/squeak-dev/2007-September/120931.html [^]

>Note that another undue sender of self is signed wiz.
SequenceableCollection>>#assertSlopesWith:from:to:
It seems this method lack a segment of code.
Additional Information This method is unused and uneeded.

SequenceableCollection>>#assertSlopesWith:from:to:
is an unsent method. It documented dynamic constraints on slopes and knots for clamped cubic spllines. I thought I had removed it.

Ahhh, the problem seems to be one of packaging

'assertSlopesWith:from:to: {Collections-Abstract}'
slipped into Collections

while the rest of the methods are packaged in Morphic e.g.
'changeInSlopes: {*Morphic-NewCurves-cubic support}'

The removal cs is uploaded below
Attached Files  removeAssertion-wiz.3.cs [^] (544 bytes) 09-25-07 20:51

- Relationships
related to 0003075closed  [Enh] in 7001 there are now Curvier polygons and curves here is the next iteration... MixedCurves 

- Notes
(0014280 - 119 - 134 - 134 - 134 - 134 - 134)
nicolas cellier
01-02-13 23:19

This method has been corrected since many months in trunk.
It is still unsend, but now packaged in Morphic.
=> closed
 

- Issue History
Date Modified Username Field Change
09-25-07 20:51 wiz New Issue
09-25-07 20:51 wiz File Added: removeAssertion-wiz.3.cs
09-25-07 20:52 wiz Relationship added related to 0003075
01-02-13 23:19 nicolas cellier Note Added: 0014280
01-02-13 23:19 nicolas cellier Status new => closed
01-02-13 23:19 nicolas cellier Resolution open => fixed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
41 total queries executed.
31 unique queries executed.
Powered by Mantis Bugtracker