Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006732 [Squeak] Etoys feature always 10-15-07 15:51 04-18-10 22:04
Reporter valente View Status public  
Assigned To andreas
Priority normal Resolution fixed  
Status closed   Product Version 3.9
Summary 0006732: Undo polygon painting cause drwaing not functioning anymore
Description When using the polygon tool of the paintbox, in Squeak 3.9, if we hit the undo botton, the tool dont draws anymore. But if we close de paint area and edit it again, the paint tool polygon came back functional.
Additional Information OS: XP and Vista 32 bits
Attached Files  polygon_error.jpg [^] (28,662 bytes) 10-15-07 15:51
 SketchPolygonUndo-M6732-Patch.1.cs [^] (516 bytes) 10-17-07 20:41
 SketchPolygonUndo-M6732-Patch.2.cs [^] (1,356 bytes) 10-17-07 20:53

- Relationships

- Notes
(0011326 - 131 - 155 - 155 - 155 - 155 - 155)
wiz
10-15-07 18:31

What did you do to before the undo button.

Please describe from a fresh image exactly how to get to the problem.

Cheers, -Jer
 
(0011327 - 333 - 339 - 339 - 339 - 339 - 339)
valente
10-15-07 19:35

Started new project. I started the painttool by openning it from the menubar. Choosed the desired color and draw a polygon. I decide to change the width of the lines, so, I hit the undo button. Surprisingly i can't draw a polygon until close the paint tool and start it again.
Used a new fresh squeak image (version 3.9, build 7067)
 
(0011340 - 525 - 609 - 609 - 609 - 609 - 609)
wiz
10-16-07 23:13

Ok.

From a fresh sq 7067
WorldMenu>Flaps>Paint Flap (paint flap appears)
Then opened the flap and selected the polygon tool
made some polygons and then
pressed undo (last polygon created disappeared)

I tried to create more polys but could not.
Then I tried the other four tools all worked even after undoing them once or twice. Then
switch back to polygon tool.
(still was unable to create more polys)

Once I tossed this drawing an created a fresh one I could again create polygons up until the first undo.
 
(0011341 - 340 - 370 - 370 - 370 - 370 - 370)
wiz
10-16-07 23:16

I was using a iMac running OS9.1 so the problem is a cross platform squeak image problem. Beyond that I haven't a clue at the moment.

Questions to answer:
Does it work in 3.8? or OPLC if so what is the difference.

For that matter what is the difference between the polygon tool and the other four tools that don't have this trouble?
 
(0011344 - 164 - 164 - 164 - 164 - 164 - 164)
valente
10-17-07 18:49

The same error is found on the 3.8.1 full image, 3.8 image from small-land and etoys of OLPC downloaded at 1st October! Dont know if it occurs on previous releases.
 
(0011345 - 121 - 127 - 127 - 127 - 127 - 127)
nicolas cellier
10-17-07 20:44

Joined a first patch attempt. Not a perfect one...
Due to the handles, polygon has a complex state handling machinery...
 
(0011346 - 33 - 33 - 33 - 33 - 33 - 33)
nicolas cellier
10-17-07 20:53

Ah Patch.2.cs is a little better.
 
(0011349 - 72 - 78 - 78 - 78 - 78 - 78)
valente
10-18-07 00:32

Many thanks Nicolas!
You are kind people. Tried the path 2. It works!!!
 
(0011678 - 104 - 152 - 152 - 152 - 152 - 152)
nicolas cellier
01-11-08 21:42

"fix begin"
Installer mantis bug: 6732 fix:'SketchPolygonUndo-M6732-Patch.2.cs'.
"fix test"
"fix end"
 
(0013331 - 65 - 65 - 227 - 227 - 227 - 227)
nicolas cellier
10-04-09 18:36

Fixed in http://source.squeak.org/trunk/MorphicExtras-nice.48.mcz [^]
 

- Issue History
Date Modified Username Field Change
10-15-07 15:51 valente New Issue
10-15-07 15:51 valente File Added: polygon_error.jpg
10-15-07 18:31 wiz Note Added: 0011326
10-15-07 19:35 valente Note Added: 0011327
10-16-07 23:13 wiz Note Added: 0011340
10-16-07 23:14 wiz Status new => confirmed
10-16-07 23:16 wiz Note Added: 0011341
10-17-07 18:49 valente Note Added: 0011344
10-17-07 20:41 nicolas cellier File Added: SketchPolygonUndo-M6732-Patch.1.cs
10-17-07 20:44 nicolas cellier Note Added: 0011345
10-17-07 20:53 nicolas cellier File Added: SketchPolygonUndo-M6732-Patch.2.cs
10-17-07 20:53 nicolas cellier Note Added: 0011346
10-18-07 00:32 valente Note Added: 0011349
01-11-08 21:42 nicolas cellier Note Added: 0011678
01-10-09 02:00 Keith_Hodges Status confirmed => pending
01-10-09 03:25 Keith_Hodges Status pending => testing
01-10-09 03:39 Keith_Hodges Status testing => resolved
01-10-09 03:39 Keith_Hodges Fixed in Version  => 3.11
01-10-09 03:39 Keith_Hodges Resolution open => fixed
01-10-09 03:39 Keith_Hodges Assigned To  => Keith_Hodges
01-10-09 03:41 Keith_Hodges Status resolved => testing
10-03-09 19:33 Keith_Hodges Status testing => assigned
10-03-09 19:33 Keith_Hodges Assigned To Keith_Hodges => andreas
10-04-09 18:36 nicolas cellier Status assigned => resolved
10-04-09 18:36 nicolas cellier Fixed in Version 3.11 => trunk
10-04-09 18:36 nicolas cellier Note Added: 0013331
04-18-10 22:04 andreas Status resolved => closed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
90 total queries executed.
52 unique queries executed.
Powered by Mantis Bugtracker