Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006740 [Squeak] VM minor always 10-25-07 06:57 05-17-11 03:30
Reporter rww View Status public  
Assigned To lewis
Priority normal Resolution fixed  
Status closed   Product Version 3.10
Summary 0006740: InterpreterSImulator - sqFile:Read:Into:At: has a nil file argument which causes it to blow up
Description In sqFile:Read:Into:At:, called when loading the sources file, has a nil file argument. The file argument comes from:

    file := self fileValueOf: (interpreterProxy stackValue: 3).

where the stackValue is 20, which is not an integer object and thus the file is
nil.
Additional Information
Attached Files

- Relationships
related to 0006555assigned lewis InterpreterSimulator raises MNU due to 3.9 refactorings 

- Notes
(0011381 - 36 - 36 - 36 - 36 - 36 - 36)
rww
10-25-07 06:58

This is in the InterpreterSimulator.
 
(0011399 - 392 - 392 - 392 - 392 - 392 - 392)
rww
10-29-07 01:59

If you specify an imageName, to start the InterpreterSimulator, that is different from the image you are running, it works. For some reason, opening the changes file with the same name as the one currently used instantiates a FileStream, but gives it a bad file handle. When the first 200 bytes are read in #openSources:andChanges:forImage:, it ends up blowing up in the FilePluginSimulator
 
(0014110 - 136 - 136 - 136 - 136 - 136 - 136)
lewis
05-17-11 03:30

To the best of my knowledge this issue is no longer present in current Squeak and VMMaker. Please re-open issue if this is not the case.
 

- Issue History
Date Modified Username Field Change
10-25-07 06:57 rww New Issue
10-25-07 06:57 rww Status new => assigned
10-25-07 06:57 rww Assigned To  => tim
10-25-07 06:58 rww Note Added: 0011381
10-27-07 20:05 matthewf Relationship added related to 0006555
10-29-07 01:59 rww Note Added: 0011399
05-27-08 18:40 tim Summary sqFile:Read:Into:At: has a nil file argument which causes it to blow up => InterpreterSImulator - sqFile:Read:Into:At: has a nil file argument which causes it to blow up
05-27-08 18:41 tim Status assigned => acknowledged
01-09-11 22:51 lewis Status acknowledged => assigned
01-09-11 22:51 lewis Assigned To tim => lewis
05-17-11 03:30 lewis Status assigned => closed
05-17-11 03:30 lewis Note Added: 0014110
05-17-11 03:30 lewis Resolution open => fixed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
55 total queries executed.
39 unique queries executed.
Powered by Mantis Bugtracker