Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006783 [Squeak] Etoys crash always 11-24-07 15:58 12-01-08 23:24
Reporter valente View Status public  
Assigned To wiz
Priority normal Resolution duplicate  
Status closed   Product Version 3.9
Summary 0006783: view objects hierarchy causing error on novice mode
Description In novice mode (squeak 3.9.7067, from squeakland) if hiting the Projects menu item "view objects hierarchy" i'm getting the "error: This message should be implemented". What can I do to solve this. It is necessary to select objcts that are outside the screen, for example.
Additional Information
Attached Files  hierarchy_objects_novice_error.jpg [^] (59,593 bytes) 11-24-07 15:58
 SqueakDebug_obj_hierarchy.log [^] (4,057 bytes) 11-24-07 22:47

- Relationships
duplicate of 0004531new  view objects hierarchy crashes squeak in smallLand theme 

- Notes
(0011466 - 935 - 1019 - 1019 - 1019 - 1019 - 1019)
wiz
11-24-07 20:29
edited on: 11-24-07 20:34

Hi Valente

AFAIK Squeakland is only suppling images based on 3.8 squeak. So I am a little puzzled by your saying this is in 3.9 7067.

In the same directory as the squeak image appears there should be a debug.log from the error. The next time this error occurs please find that an upload it. It will have vital info as to what went wrong.

Note: the debug.log will get overwritten with each new error. So you need to find it just after the error occurs. (I usually immediately rename it so that the next error will not clobber it.)

Can you describe from a fresh sqeauk exactly how to reproduce the error. Include any preferences you set (I notice from the picture that the world is being called mundo so some spanish translation seems to be going on.) I can not see from the picture if you have the docking bar enabled.

Anyway good bug find and thanks for the report.

Yours in curiosity and service, --Jerome Peace

 
(0011473 - 243 - 267 - 267 - 267 - 267 - 267)
valente
11-24-07 22:52
edited on: 11-24-07 22:57

Hi wiz,
You are right. This isn't the squeakland version, it is the squeak.org 3.9 7067 last build. I've squeakland plugin too and made confusion. Sorry.
I've uploaded the log created after the error. Sorry i messed it in my previous post.

 
(0011478 - 461 - 533 - 533 - 533 - 533 - 533)
wiz
11-25-07 21:59
edited on: 11-25-07 22:00

Hi valente,

The log was valuable. It reminded me of something familiar.

This complaint is the duplicate of something I fixed for 3.9 but which apparently never got in.

Your report here was important in realizing that action still needed to be taken.

The patch in the other report should solve your problem. You are now the official user tester for the patch. If there are problems with it please mention them in the other report.

Cheers - Jer.

 
(0011479 - 297 - 327 - 327 - 327 - 327 - 327)
valente
11-25-07 22:25

The solution you propose function very well but only if loaded with filein. When trying to load with the install option on a file list browser it returns that the name is already in use.
Many thanks

Valente

PS: I'm translating Squeak 3.9 to Portuguese (Portugal) to use it in a PhD research
 
(0012822 - 18 - 18 - 18 - 122 - 122 - 122)
KenCausey
12-01-08 23:24

duplicate of 0004531
 

- Issue History
Date Modified Username Field Change
11-24-07 15:58 valente New Issue
11-24-07 15:58 valente File Added: hierarchy_objects_novice_error.jpg
11-24-07 20:29 wiz Note Added: 0011466
11-24-07 20:34 wiz Note Edited: 0011466
11-24-07 22:47 valente File Added: SqueakDebug_obj_hierarchy.log
11-24-07 22:52 valente Note Added: 0011473
11-24-07 22:57 valente Note Edited: 0011473
11-25-07 21:47 wiz Relationship added duplicate of 0004531
11-25-07 21:59 wiz Note Added: 0011478
11-25-07 21:59 wiz Status new => resolved
11-25-07 21:59 wiz Resolution open => duplicate
11-25-07 21:59 wiz Assigned To  => wiz
11-25-07 22:00 wiz Note Edited: 0011478
11-25-07 22:25 valente Note Added: 0011479
12-01-08 23:24 KenCausey Status resolved => closed
12-01-08 23:24 KenCausey Note Added: 0012822


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
71 total queries executed.
41 unique queries executed.
Powered by Mantis Bugtracker