Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006791 [Squeak] Morphic major always 11-29-07 07:03 07-03-09 00:27
Reporter wiz View Status public  
Assigned To wiz
Priority low Resolution duplicate  
Status assigned   Product Version
Summary 0006791: Keyboarding on a menu is trying to serve two conflicting purposes.
Description The following is a description and analysis of what happens on most menus:


If you have the shift key down when you press the mouse the label editor activates (menu becomes twice as wide with the selection you are on highlighted once in red then in black . You can type one letter and that replaces the label. Subsequent typing "filters the menu" by elimiating labels that do not match what is typed.

Basicly this is two features in confilct.

One circa 1999 (di and ar) meant to allow dynamicly changing menu labels.

The other added later meant for selecting menu items via keyboard input.

The second steals and hordes keyboard focus after the first keystroke.

I haven't looked for the problems but it would seem the next step is to decide what is to go. I supect the label editing feature should be eliminated for now.

Additional Information This was first mentioned in 0001780 but it clearly deserves its own report and followup.

Attached Files

- Relationships

SYSTEM WARNING: Creating default object from empty value

SYSTEM WARNING: Creating default object from empty value

duplicate of 0006699new  Menu keyboarding works poorly and conflicts with menu label editing 
related to 0001780pending matthewf Stay up menus have a confusing and dangerous behavior when obscured. 
child of 0006635new  Mother of Squeak UI annoyances 

- Notes
(0011551 - 191 - 203 - 203 - 203 - 203 - 203)
wiz
12-17-07 04:29

Hi Matthew, thanks for pointing out the relation with 6699. On reflection I decided to treat this report as the duplicate as the other is a little more precise and explanitory.

Cheers- Jer
 
(0013144 - 91 - 91 - 91 - 91 - 91 - 91)
KenCausey
07-03-09 00:27

Reopening the issue, status of dupes should match the status of the other existing matches.
 

- Issue History
Date Modified Username Field Change
11-29-07 07:03 wiz New Issue
11-29-07 07:05 wiz Relationship added child of 0006635
11-29-07 07:05 wiz Relationship added related to 0001780
12-17-07 04:07 matthewf Relationship added related to 0006699
12-17-07 04:26 wiz Relationship replaced duplicate of 0006699
12-17-07 04:27 wiz Status new => resolved
12-17-07 04:27 wiz Resolution open => duplicate
12-17-07 04:27 wiz Assigned To  => wiz
12-17-07 04:29 wiz Note Added: 0011551
07-03-09 00:27 KenCausey Note Added: 0013144
07-03-09 00:27 KenCausey Status resolved => assigned


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
56 total queries executed.
39 unique queries executed.
Powered by Mantis Bugtracker